Discovery Visual Environment User Guide

About this Manual

Contents

Chapter 1 — Overview
Chapter 2 — Getting Started
Chapter 3 — Using the Top Level Window
Chapter 4 — Using The Wave Window
Chapter 5 — Working with Assertions
Chapter 6 — Using the List Window
Chapter 7 — Using Schematics
Chapter 8 — Displaying Delta Cycles
Chapter 9 — Basic Navigation Techniques

Index
# Contents

## 1. Overview

- Primary DVE Components ........................................ 1-2
- Top Level Window ............................................. 1-2
- Status Bar ...................................................... 1-5
- Source Window ................................................ 1-6
- Assertion Window ............................................ 1-7
- Wave Window .................................................. 1-8
- List Window .................................................... 1-11
- Schematic Window ............................................ 1-12
- DVE Usage Flow ................................................ 1-14
- Debugging VCS and VCS MX Designs ....................... 1-14
- Designs with Assertions (post-processing) ............. 1-17
- Key Terms and Concepts ..................................... 1-19

## 2. Getting Started

- Enabling Debugging ........................................... 2-2
- Starting DVE .................................................... 2-3
- Running a Quick Start Example ............................ 2-4
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening a Database</td>
<td>2-6</td>
</tr>
<tr>
<td>Setting Up and Starting an Interactive Session</td>
<td>2-7</td>
</tr>
<tr>
<td>Running the Simulation</td>
<td>2-9</td>
</tr>
<tr>
<td>Using the Hierarchy Browser</td>
<td>2-12</td>
</tr>
<tr>
<td>Expanding Scopes Individually</td>
<td>2-12</td>
</tr>
<tr>
<td>Expanding Multiple Scopes or by Level</td>
<td>2-13</td>
</tr>
<tr>
<td>Loading the Variable Pane and Source Window</td>
<td>2-14</td>
</tr>
<tr>
<td>Using Breakpoints in Interactive Simulation</td>
<td>2-16</td>
</tr>
<tr>
<td>Line Breakpoints</td>
<td>2-16</td>
</tr>
<tr>
<td>Line, Time and Signal Condition Breakpoints</td>
<td>2-17</td>
</tr>
<tr>
<td>Viewing Assertion Data</td>
<td>2-19</td>
</tr>
<tr>
<td>Viewing Waveform Information</td>
<td>2-20</td>
</tr>
<tr>
<td>Viewing Source Code</td>
<td>2-24</td>
</tr>
<tr>
<td>Viewing Tabular Data</td>
<td>2-25</td>
</tr>
<tr>
<td>Saving a Session</td>
<td>2-26</td>
</tr>
<tr>
<td>Loading a Saved Session</td>
<td>2-27</td>
</tr>
<tr>
<td>Closing a Database</td>
<td>2-28</td>
</tr>
<tr>
<td>Exiting DVE</td>
<td>2-28</td>
</tr>
<tr>
<td>3. Using the Top Level Window</td>
<td></td>
</tr>
<tr>
<td>Using the Menu Bar and Toolbar</td>
<td></td>
</tr>
<tr>
<td>Menu Bar Reference</td>
<td>3-4</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>3-19</td>
</tr>
<tr>
<td>Toolbar Reference</td>
<td>3-22</td>
</tr>
<tr>
<td>Managing DVE Windows</td>
<td></td>
</tr>
<tr>
<td>Displaying Data in a New Top-Level Window</td>
<td>3-25</td>
</tr>
</tbody>
</table>

Table of Contents
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Docking and Undocking Windows and Panes</td>
<td>3-26</td>
</tr>
<tr>
<td>Setting Display Preferences</td>
<td>3-26</td>
</tr>
<tr>
<td>Using the Hierarchy Browser</td>
<td>3-28</td>
</tr>
<tr>
<td>Navigating the Hierarchy</td>
<td>3-30</td>
</tr>
<tr>
<td>Scope Types and Icons</td>
<td>3-34</td>
</tr>
<tr>
<td>Using the Data Pane</td>
<td>3-36</td>
</tr>
<tr>
<td>Rearranging Hierarchy Information</td>
<td>3-38</td>
</tr>
<tr>
<td>Viewing Multiple Designs</td>
<td>3-39</td>
</tr>
<tr>
<td>Using Context Sensitive Menus</td>
<td>3-40</td>
</tr>
<tr>
<td>Using Source Windows</td>
<td>3-41</td>
</tr>
<tr>
<td>Loading Source Code</td>
<td>3-42</td>
</tr>
<tr>
<td>Using the mouse in the Source Window</td>
<td>3-46</td>
</tr>
<tr>
<td>Working with the Source Window</td>
<td>3-47</td>
</tr>
<tr>
<td>Setting Time Units and Precision</td>
<td>3-55</td>
</tr>
<tr>
<td>Managing Breakpoints in Interactive Simulation</td>
<td>3-56</td>
</tr>
<tr>
<td>Creating Line Breakpoints</td>
<td>3-56</td>
</tr>
<tr>
<td>Creating a Time Breakpoint</td>
<td>3-59</td>
</tr>
<tr>
<td>Creating a Signal Breakpoint</td>
<td>3-60</td>
</tr>
<tr>
<td>Enabling, Disabling, and Deleting Breakpoints</td>
<td>3-61</td>
</tr>
<tr>
<td>Displaying Drivers and Loads</td>
<td>3-62</td>
</tr>
<tr>
<td>Displaying an Active Driver</td>
<td>3-62</td>
</tr>
<tr>
<td>Displaying an Active Load</td>
<td>3-64</td>
</tr>
<tr>
<td>Displaying Memory</td>
<td>3-65</td>
</tr>
<tr>
<td>Customizing Memory Display</td>
<td>3-66</td>
</tr>
<tr>
<td>Using the Console</td>
<td>3-67</td>
</tr>
<tr>
<td>Log View</td>
<td>3-68</td>
</tr>
<tr>
<td>History View</td>
<td>3-69</td>
</tr>
</tbody>
</table>
Errors/Warnings View ................................. 3-70
Command Line ........................................... 3-72

4. Using The Wave Window
Viewing Waveform Information ......................... 4-2
  Setting Wave Window Preferences .................... 4-4
Using the Signal Pane .................................. 4-5
  The Display Radix .................................... 4-6
  Expanding Verilog Vectors, Integers, Time and Real Numbers . 4-6
Using User-Defined Mnemonic Radices .................. 4-7
  Creating a User-Defined Radix ....................... 4-7
  Managing User-Defined Radices ...................... 4-8
  Importing and Exporting a User-Defined Radices .......... 4-8
Setting Signal Groups .................................. 4-9
Using the Waveform Pane ............................... 4-10
  How The Wave Window Displays Values ................. 4-12
  Displaying Analog Waveforms ......................... 4-14
  Cursors and Markers .................................. 4-15
  Using The Markers Dialog Box ......................... 4-18
  Drag Zooming ........................................ 4-19
  Expanding and Contracting Wave Signals ............... 4-20
  Searching in the Graphical Panes ..................... 4-20
  Customizing the Display ................................ 4-21
Comparing Signals, Scopes, and Groups ................. 4-22
Building Buses .......................................... 4-24
Shifting Signals ........................................ 4-29
5. Working with Assertions

- Compiling SystemVerilog Assertions. ........................................ 5-4
- Using the Assertion Failure Summary Tab ............................. 5-4
- Using the Assertions Tab .................................................. 5-6
  - Customizing the Display .............................................. 5-8
  - Opening Assertion Display in a Top-Level Window ............ 5-9
- Displaying Assertion Attempts in the Waveform Window ........ 5-9
  - Viewing Assertion Failures ........................................ 5-10
- Assertions in The Signal Pane ....................................... 5-12
- Navigating Source Code ................................................. 5-15

6. Using the List Window

- The List Window .......................................................... 6-2
- Displaying Data .......................................................... 6-3
  - Dragging and Dropping Signals into the List Window .......... 6-3
  - Opening a Database .................................................... 6-3
  - Loading a Session ..................................................... 6-4
- Navigating Simulation Data .............................................. 6-4
  - Viewing Data in the List Window .................................. 6-4
- Using Markers ............................................................. 6-6
- Customizing the Display ............................................... 6-7
  - Setting Preferences .................................................... 6-8
  - Setting Signal Properties ........................................... 6-9
- Comparing Signals ....................................................... 6-10
- Saving a List Format ..................................................... 6-13
# Table of Contents

## 7. Using Schematics
- Overview ....................................................................... 7-2
- Managing Schematic Displays ....................................... 7-3
  - Customizing the Display .............................................. 7-4
  - Displaying Schematic Graphics .................................... 7-6
  - Using the Context-Sensitive Menu ................................. 7-7
- Opening a Design Schematic View .................................. 7-7
- Opening a Path Schematic View ...................................... 7-10
- Manually Tracing Signals .............................................. 7-14
- Following a Signal Across Boundaries ............................. 7-15
- Tracing X Values in a Design .......................................... 7-16

## 8. Displaying Delta Cycles
- Delta Cycle Recording for Verilog ................................. 8-1
- Delta Cycle Recording for VHDL ..................................... 8-2
- Delta Cycle Recording for Mixed Designs for VCS MX ...... 8-3
- Using Delta Cycles ....................................................... 8-3
- Expand and Collapse Times .......................................... 8-3
- View Delta Cycles ....................................................... 8-4

## 9. Basic Navigation Techniques
- Using Mouse Buttons .................................................. 9-1
  - Selecting Scopes, Variables, Assertions, and Text .......... 9-3
  - Dragging and Dropping Data into the Waveform Window .. 9-4
- Using Context Sensitive Menus ...................................... 9-6
Using Toolbar Icon Sets as Floating Tool Palettes ............... 9-13
Minimizing, Maximizing, and Moving Toolbar Icon Sets ........... 9-16
About this Manual

This manual explains the use of Discovery Visual Environment (DVE) for running and debugging active simulations and historical records of simulations and where appropriate, provides conceptual information to help you understand the application of DVE features.

This preface covers the following topics:

• Audience
• Licensing
• Platforms
• Other sources of information
• Conventions
Audience

The DVE User Guide provides product description, tutorial, and reference information to help you use the DVE simulation debug environment.

The information in this document serves as a primary reference source and procedural guide for DVE users. This guide assumes that the user has the following background.

- Working knowledge of hardware design languages (HDLs), the construction of designs, verification tools, and a working knowledge of HDL simulators.

The DVE licenses float and are independent of each other.

Other Sources of Information

For more information about DVE and other Synopsys products, refer to the following sections.

SOLV-IT! Online Help

SOLV-IT! is the Synopsys electronic knowledge base. It contains information about Synopsys and its tools and is updated daily.

Access SOLV-IT! through e-mail or through the World Wide Web (WWW). For more information about SOLV-IT!, send e-mail to

solvitfb@synopsys.com

or view the Synopsys Web page at

http://www.synopsys.com
Customer Support

If you have problems, questions, or suggestions, contact the DVE technical support in one of the following ways:

- Send e-mail to vcs_support@synopsys.com
- Call 1-800-837-4564 (1-800-VERILOG)
About this Manual
Overview

Discovery Visual Environment (DVE) software is a graphical verification environment that supports debugging for VCS and VCS MX simulations. This release of DVE allows you to work in post-processing and interactive mode.

Using DVE, you can perform the following tasks:

• Hierarchically expand and view HDL scope information related to assertions.

• Debug assertions.

• View log, history, and error/warning information related to your analysis.

• Perform TCL tasks by executing scripts from the DVE graphical user interface or executing TCL commands or sourcing scripts through the command-line interface.
Primary DVE Components

This section provides an overview of the following core components of DVE:

- Top Level Window
- Source Window
- Assertion Window
- Wave Window
- List Window
- Schematic Window

Top Level Window

The Top Level Window is a frame that can contain the other windows. A Top Level Window has menus, toolbars and statusbar. From the Top Level Window, you can:

- Use the Menu bar, Toolbar, and Status Bar to run and interact with a simulation or open, view, navigate, edit, and close a design database and set the target for new panes and windows containing source code, waveforms, schematics, and ASCII data. You can specify analysis and search parameters, invoke TCL scripts, run examples, and access Help.

- Use the Hierarchy Browser to view, expand, and select scopes of interest for display in a Waveform Window.
• View and filter signal information. Double click a signal of interest to view source code or drag and drop it into another DVE pane or window. Dragging and dropping is supported in the Data Pane, Source, Wave, List, and Assertion windows.

• View HDL or Assertion source code in the Source Window or in multiple Source Windows.

• View assertion failures and history.

• Perform TCL tasks by executing scripts from the DVE graphical user interface or executing TCL commands or sourcing scripts through the command-line interface.

• Activate any open DVE window or pane regardless of where it is in the desktop window stack.

• Access DVE windows, such as the Waveform Window and List Window, to debug your design.

The basic techniques for using the Top Level Window are described in detail in Chapter 3, "Using the Top Level Window."

Figure 1-1 shows an example of the Top Level Window.
Figure 1-1  DVE Top Level Window Initial View

Overview
Status Bar

The status bar in the lower left corner of the Top Level Window displays information about your simulation. Figure shows the information displayed in the status bar boxes.

Figure 1-2  Status Bar

The number of selected objects in the Hierarchy browser, source window, or schematic browser.

The current scope of the Hierarchy browser, source window, or schematic browser.

Target window selection icons.

The name of selected objects in the Hierarchy browser, source code window, or schematic browser.

The current status of the simulator

The current time of the design
Source Window

In addition to viewing source code in the Source Window, you can open multiple tabs or freestanding Source Windows. You display HDL, testbench, and assertion source code by double-clicking an item in a list or by dragging and dropping a signal or assertion from another DVE window.

Figure 1-3  Source Window

```plaintext
#include "systemc.h"

SC_MODULE(sc_subtracter)
{
public:
  sc_in<sc_lv<32> > ina;
  sc_in<sc_lv<32> > inb;
  sc_out<sc_lv<32> > outx;

  SC_CTOR(sc_subtracter)
  : ina("ina")
  , inb("inb")
  , outx("outx")
  {
    SC_METHOD(sc_subtracter_action);
    sensitive << ina << inb;
  }

  void sc_subtracter_action() {
    outx.write(ina.read().get_word(0) - inb.read().get_word(0));
  }
}
```

Line Attributes

Code Display
Assertion Window

Use the Assertion Window tabs to view assertions and assertion failures:

- **Assertion Failure Summary tab**: Displays a summary of one failed attempt for every failing assertion. By default, the failed attempt is the first attempt that failed.
- **Assertions tab**: Totals results for all assertions in a selected block or scope. Also allows analysis of results of specific assertion attempts.

![Figure 1-4 Assertion Window tabs](image)

**Columns**
- **First Fail Ended**
- **First Fail Started**
- **Delta**
- **Type**
- **Instance**
- **Assertion**
- **Failures**
- **Incomplete**
- **Success**
- **Attempts**

![Assertion Data](image)

**Column Headers**
- **Tabs**
- **Column Headers**
- **Assertion Failure Data**
- **Assertion Data**

![Assertion Failure Summary](image)
Wave Window

The Wave Window displays

- Waveforms of selected signals in your design.
- Trace information for a particular assertion, along with a waveform of the signals and expressions associated with the assertion.

Displaying Signals in the Wave Window

Use the Wave Window to view and highlight signals of interest, advance to various simulation times, and view simulation time deltas.

To view signals in the Waveform Window, you can double click an assertion summary item or an attempt, drag and drop an item in a list or select an item and select Add to Waves from the menu.

Figure 1-5 shows an example of the Waveform Window displaying signals. Cursor 1 (C1) indicates current time.
Viewing Assertions and Assertions Attempts

You debug assertions by first displaying information for a particular assertion failure in the Assertion Window. You can then examine a waveform of the signals. All trace information is color-coded for easy readability and analysis.

Typically, you access and view an assertion by double-clicking a particular assertion in either of the following windows:

- The Assertion Window (located in the Console of the Top Level Window)
- The Hierarchy Browser by navigating to the assertion.
Or you can drag and drop an OVA assertion unit from the Hierarchy Browser or an OVA or SVA assertion from the Data Window into the the Wave Window (double click to display the source code in the Source Window).

You can then view a trace of a failed assertion by double clicking a failed attempt (a red up arrow) in the Wave Window.

Figure 1-6 shows an example of the Waveform Window. displaying a trace of a failed assertion attempt. The cursors mark the start and end times of the failure and the background color is also different to indicate the assertion time region. This lighter color persists if the cursors are moved to make it easy to identify the assertion region.
List Window

Use the List Window to generate ASCII simulation results. The List Window displays simulation data as shown in the Wave Window but in tabular format. It is a scrollable window, showing simulation time on the left.
Schematic Window

Schematic views provide a compact, easy-to-read graphical representation of a design. There are two types of schematic views in DVE: design and path.

- A design schematic shows the hierarchical contents of a design or a selected instance and lets you traverse the hierarchy of the design.
A path schematic is a subset of the design schematic displaying where signals cross hierarchy levels. Use the path schematic to follow a signal through the hierarchy and display portal logic (signal effects at ports).
Figure 1-9  Path Schematic

DVE Usage Flow

Debugging VCS and VCS MX Designs

VCS and VCS MX in Post-Processing Mode

The following steps outline the general flow for using DVE with VCS and VCS MX in post-processing mode:

Overview
1-14
1. For post-processing using VCS MX mixed HDL, Verilog-only, or VHDL-only designs, run the appropriate simulator to create a VPD file. See the *VCS MX User Guide* or the *VCS User Guide* for complete instructions.

2. Start DVE and open the VPD file.

3. Use the Hierarchy Browser to find an HDL signal.

4. Populate the Data Pane and Source Window. A single click populates the Data Pane. A double click populates both the Data Pane and the Source Window.

   Note that information displayed in the DVE interface is cross-linked.

5. Investigate the design results by doing the following:
   - View source code information in the Source Window.
   - Trace signal waveform information in the Wave Window.
   - View signal data in tabular format in the List Window.
   - View the design graphically in the Schematic Window and the Path Schematic Window.

6. View waveform information for selected signals by opening the Wave Window and dragging and dropping scopes from the Hierarchy Browser.

7. View additional assertion and scope information by dragging and dropping HDL signals of interest from the Hierarchy Browser or Data Window to the Wave Window.
VCS and VCS MX in Interactive Mode

The following steps outline the general flow for using DVE with VCS MX in interactive mode:

1. For interactive debugging using VCS MX mixed HDL, Verilog-only, or VHDL-only designs, first compile your design. See the VCS MX User Guide or the VCS User Guide for complete instructions.

2. Start DVE and open the compiled design file.

3. Use the toolbar commands to navigate through the design.

   Or

   Use the command line to enter TCL and Unified Command Line Interface commands.

4. Use the Hierarchy Browser to view design structure and find HDL signals.

5. Populate the Data Pane and Source Window. A single click populates the Data Pane. A double click populates both the Data Pane and the Source Window.

   Note that information displayed in the DVE interface is cross-linked.

6. Use the Source Window or the command line to set breakpoints in your design.

7. Investigate the design results by doing the following:

   - View source code information in the Source Window.
   - Trace signal waveform information in the Wave Window.
   - View signal data in tabular format in the List Window.
8. View waveform information for selected signals by opening the Wave Window and dragging and dropping scopes from the Hierarchy Browser.

9. View additional assertion and scope information by dragging and dropping HDL signals of interest from the Hierarchy Browser or Data Window to the Wave Window.

---

**Designs with Assertions (post-processing)**

The following steps outline the general flow for using DVE with assertions:

1. For post-processing using HDL and assertion source files, run the appropriate simulator to create a VPD file. This process integrates assertion data within the VPD file.

   Note: Use the VCS -assert dve command line switch with the -PP flag to enable SVA tracing in DVE. If you do not enable SVA tracing, assertion value changes will still be dumped into the VPD file and be visible in the Wave Window, but assertion attempts cannot be traced.

2. Start DVE and open the VPD file.

3. Use the Hierarchy Browser to find an HDL signal or an assertion or use the Assertion Failure Summary tab to identify an assertion failure.

4. Populate the Data Pane and Source Window. A single click populates the Data Pane. A double click populates both the Data Pane and the Source Window.

   Note that information displayed in the DVE panes windows is cross-linked.
5. In the Assertion Window, double click an assertion failure in the Assertion Failure Summary tab to populate the Assertion tab with data for the assertion unit the failed assertion belongs to. In the assertion tab, expand the tree, and review detailed assertion statistics, such as assertion attempts, failures, successes and incomplete attempts, as well as start/end times, and reasons for failures. Double clicking also populates the Wave Window with trace information and displays all the pertinent source files.

6. Investigate the cause of an assertion failure by doing the following:

   - View source code information in the Source Window.

   - Trace assertion and related signal waveform information in the Wave Window.

   - View signal data in tabular format in the List Window.

7. View waveform information for selected signals by opening the Wave Window and dragging and dropping scopes from the Hierarchy Browser.

8. View additional assertion and scope information by dragging and dropping HDL signals of interest from the Hierarchy Browser or Data Window to the Wave Window.
### Key Terms and Concepts

*The DVE User Guide* uses the following terms and concepts in feature descriptions and procedures:

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Assertion</strong></td>
<td>An OVA or SVA statement used to specify design behavior. An assertion is used as a monitor to detect incorrect design behavior in dynamic simulation, or as a property to be proven exhaustively using formal verification.</td>
</tr>
<tr>
<td><strong>Assertion Attempt</strong></td>
<td>A specific instance of an assertion (a specific firing of an assertion).</td>
</tr>
<tr>
<td><strong>Context Sensitive Menu (CSM)</strong></td>
<td>A menu that pops up when you right click on a particular item. The menu selections vary depending on the particular item you clicked.</td>
</tr>
<tr>
<td><strong>Drag and Drop</strong></td>
<td>Position your mouse pointer on a GUI object (such as a signal or scope name) press and hold down your left mouse button, move your mouse to a different location, then release the mouse button. In DVE, you can drag scopes and signals from one window or dialog and drop them into another window or dialog.</td>
</tr>
<tr>
<td><strong>Expand and Collapse</strong></td>
<td>Click on a plus (+) symbol to expand or a minus (-) symbol to collapse a hierarchy tree.</td>
</tr>
<tr>
<td><strong>OVA</strong></td>
<td>OpenVera Assertions — a declarative method that describes sequences of events and facilities to test for their occurrence.</td>
</tr>
<tr>
<td><strong>Pane</strong></td>
<td>Panes are sub-windows within DVE windows that display specific types of information. For example, the Waveform Window contains separate panes for signal names, signal values, and signal waveforms.</td>
</tr>
<tr>
<td><strong>Scope (Verilog)</strong></td>
<td>In Verilog, a scope is defined as any instance of a module, task, function, or named block in the Verilog Hardware Description Language (HDL) source code.</td>
</tr>
<tr>
<td><strong>Scope (VHDL)</strong></td>
<td>In VHDL, a scope is any instance of an entity/architecture component. (The entity/architecture component is analogous to a module in the Verilog language.) Blocks, Packages, Processes, Procedures, and Functions are also considered scopes.</td>
</tr>
</tbody>
</table>
SVA

SystemVerilog Assertions — a declarative method that describes sequences of events and facilities to test for their occurrence. SVA is part of the proposed SystemVerilog extension to the Verilog language.

Note: Use the VCS `--assert dve` command line switch with the `--PP` flag to enable SVA tracing in DVE. If you do not enable SVA tracing, assertion value changes will still be dumped into the VPD file and be visible in the Wave Window, but assertion attempts cannot be traced.

Variable or Signal (Verilog)

In Verilog, the term "variable" is used interchangeably with the term "signal". Variable was adapted from the standard VCD technology and can refer to any of the following Verilog terms: Net, Reg, Real Number, Integer, Named Event, and Time Variable.
<table>
<thead>
<tr>
<th><strong>Variable and Signal (VHDL)</strong></th>
<th>The VHDL language distinguishes between signals and variables. In general, DVE uses the term signals to refer to both signals and variables. There are some exceptions to this rule, but these exceptions are either explicitly stated or implied by the context of its usage. (For example, a dialog that has both a selection for Signals and a selection for Variables is obviously distinguishing between the two.) It is also important to recognize that because most variables are dynamic, simulators may not trace them and consequently they will not show up in the hierarchy.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Verilog Language</strong></td>
<td>DVE uses standard Verilog and SystemVerilog terms, including the language, keywords, syntax, system tasks, and PLI calls.</td>
</tr>
<tr>
<td><strong>VHDL Language</strong></td>
<td>DVE uses standard VHDL terms including the language, keywords, syntax, etc.</td>
</tr>
<tr>
<td><strong>Window</strong></td>
<td>An area of the screen that displays the user interface for a DVE application. A window can contain a menubar, a toolbar, and panes that display specific types of information.</td>
</tr>
</tbody>
</table>
This chapter describes the basic techniques for getting started using DVE. The following topics are covered:

- Enabling Debugging
- Starting DVE
- Running a Quick Start Example
- Opening a Database
- Using the Hierarchy Browser
- Loading the Variable Pane and Source Window
- Viewing Waveform Information
- Viewing Source Code
- Viewing Tabular Data
• Exiting DVE

Enabling Debugging

This section describes how to enable debugging options for your simulation.

Compile-Time Options

- **-debug**
  Enables DVE and command line debugging option. This option does not enable line stepping.

- **-debug_all**
  Enables command line debugging option including line stepping.

- **-debug-pp**
  Creates a VPD file (when used with the VCS system task $vcdpluson) and enables DVE for post-processing a design. Using `-debug-pp` can save compilation time by eliminating the overhead of compiling with `-debug` and `-debug_all`.

- **-ucli**
  Forces runtime to go into UCLI mode by default. Also see the following section, Runtime Options, for more information.

- **-gui**
  When used at compile time, starts DVE at runtime. Also see the following section, Runtime Options, for more information.

For a complete description of command line options, see the VCS User Guide and the VCS MX User Guide.
## Runtime Options

- **-gui**
  Invokes DVE at runtime.

- **-ucli**
  Invokes the UCLI debugger command line if issued at runtime. Also see the previous section, Compile-Time Options, for more information.

- **-l logFilename**
  Captures simulation output, such as user input commands and responses to UCLI commands.

- **-i inputFilename**
  Reads interactive commands from a file, then switches to reading from standard command line input.

- **-k keyFilename**
  Writes interactive commands entered to keyFilename, which can be used by a later simv as -i inputFilename

### Starting DVE

To start DVE, enter the -gui runtime option. For example, to run DVE with a VCS simulation, enter:

```bash
% simv -gui
```

The DVE Top Level Window appears displaying the Hierarchy Browser, Data Pane, Source Wndow, and Console.

Note that to enable line stepping in your simulation, you must use the -debug_all compile-time option when compiling your design.
See Figure 2-1 for an example of the initial appearance of the DVE Top Level Window.

**Figure 2-1  Initial appearance of the Top Level Window**

Running a Quick Start Example

DVE includes an example database you can use to become familiar with some of its basic usage techniques.

To load the quick start example shipped with DVE:
1. Create and change directories to a work directory where simulation files can be written (DVE will run the testcase simulation).

2. In the Toolbar of the Top Level Window, click the example icon denoted by the lightening bolt.

DVE runs the simulation and loads it. Note that data initially appears in the Hierarchy Browser within the Top Level Window.

Figure 2-2  Initial Appearance of Quick Start Example
If you select an example with assertions, the Assertion Window also opens and displays the Assertion Failure tab as shown in Figure 2-3.

**Figure 2-3  Assertion Window displaying Assertion Failure Summary tab:**

---

**Opening a Database**

In addition to the quick start example, you can load and display any number of VPD files for post-processing. To open a database in DVE:

1. Do either of the following:
   - From the Menu bar, select **File>Open Database**.
   - From the Toolbar, click the Open Database icon 📁 .

The Open Database dialog box appears.
2. In the Open Database dialog box, browse and select the name of the VPD file you want to load.

3. Enter or accept a Designator for your design.

4. Enter a time range to load.

5. Click **OK**.

DVE loads the selected VPD file.

---

**Setting Up and Starting an Interactive Session**

In addition to loading VPD files for post-processing, you can also setup and run a simulation interactively in real-time using a compiled Verilog, VHDL, or mixed design.
1. Select **Simulator>Setup** to display the Simulation Setup dialog box (see Figure 2-5).

![Simulation Setup Dialog](image)

**Figure 2-5**

2. Browse to a simulator executable if renamed.

3. Select simulator arguments. You can enable line stepping and value compile by entering debug_all.

4. Select or browse to an interactive .vpd file.

5. Click OK to set up the simulation.
Running the Simulation

This section describes using DVE to run and control the simulation. The following topics are covered:

- Using the Toolbar
- Using Simulator Menu Commands
- Using the Command Line

Using the Toolbar

When you start the simulation, DVE activates toolbar commands for running and controlling the simulation. Click the following icons in the toolbar to control the simulation.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Stop Icon" /> Stop</td>
<td>When the simulation is running, this icon is activated. Click to stop the simulation.</td>
</tr>
<tr>
<td><img src="image" alt="Continue Icon" /> Continue</td>
<td>Continue until the next valid breakpoint (monitor), user interrupt, or the end of simulation.</td>
</tr>
<tr>
<td><img src="image" alt="Step Icon" /> Step</td>
<td>Move the simulation forward in time as set by the Simulator&gt;Set Step Time command. step will step into task and functions.</td>
</tr>
</tbody>
</table>
Using Simulator Menu Commands

After you start the simulation, you can use menu commands to run and control the simulation. Select the following commands to control the simulation.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop</td>
<td>Stops the simulation.</td>
</tr>
<tr>
<td>Continue</td>
<td>Continue until the next valid breakpoint (monitor), user interrupt, or the end of simulation.</td>
</tr>
<tr>
<td>Step</td>
<td>Move the simulation forward in time as set by the Simulator&gt;Set Step Time command. <code>step</code> will step into task and functions.</td>
</tr>
<tr>
<td>Next</td>
<td>For Verilog code, next steps over tasks and functions.</td>
</tr>
<tr>
<td>Terminate</td>
<td>Finishes simulation and ends the interactive session.</td>
</tr>
</tbody>
</table>
Using the Command Line

Use the command line at the bottom of the DVE top level window to enter DVE and Unified Command Line Interface (UCLI) commands to run and control your simulation. Figure 2-6 shows the command line where you enter commands with the results displayed in the Log tab above the command line.

Figure 2-6  Command Line with the Log tab

To view DVE commands, enter

```
help -gui
```

For complete information on using UCLI, see the Unified Command Language User Guide. For a quick view of the UCLI commands and their use, at the DVE command prompt, enter

```
help -ucli [argument]
```

When entered without an argument, a list of UCLI commands and a short description is displayed. Enter a command name as the argument, and a description and command syntax are displayed.
The UCLI commands and definitions are displayed.

---

**Using the Hierarchy Browser**

Use the Hierarchy Browser to navigate designs. When multiple designs are open, you can select which design to display from the pulldown menu and filter the signals displayed in the hierarchy. When a design is initially loaded in DVE, the scopes will appear in a collapsed view within the Hierarchy Browser.

---

**Expanding Scopes Individually**

1. In the Hierarchy Browser, click on a icon, located to the left of a scope.

The hierarchy tree expands, as shown below.
2. Continue to click the icons to expand the hierarchy tree.

---

### Expanding Multiple Scopes or by Level

1. With a scope selected in the Hierarchy Browser, right-click, select **Edit > Expand by Levels**, then select the level as shown below (You can also right-click to display the context-sensitive menu):

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand By Levels</td>
<td>Allows expansion by multiple levels with a single action.</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expands the entire hierarchy at once. There may be a delay getting the hierarchy from the simulation when working interactively.</td>
</tr>
</tbody>
</table>

2. Select a command according to the following:
Loading the Variable Pane and Source Window

After identifying a scope of interest in the Hierarchy Browser, you can load, filter, and view detailed variable data and source code for a scope and filter variables displayed.

To load data in the Variable Pane and Source Window:

1. Make sure a database is currently loaded in the Hierarchy Browser.

2. Do either of the following:
   - To populate the Variable Pane with data, click a scope icon in the Hierarchy Browser.
   - To populate the Source Window, select Scope > Show Source. See Figure 2-7.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collapse</td>
<td>Collapses the selected scope.</td>
</tr>
<tr>
<td>Collapse All</td>
<td>Collapses all expanded scopes.</td>
</tr>
<tr>
<td>Select Levels</td>
<td>Allows selection of scopes by multiple levels.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects the entire hierarchy.</td>
</tr>
</tbody>
</table>
Figure 2-7  Appearance of data in the Variable Pane and Source Window

Selected scope

Variable Pane

Source Pane displays source code

Getting Started

2-15
Using Breakpoints in Interactive Simulation

When you are working in an interactive session, you can set breakpoints to stop a running simulation at specified lines, times, or signal conditions. This section describes using DVE to create, view, edit, enable, disable, and delete breakpoints.

Note: To use line breakpoints, you must have compiled your design using the `-debug_all` compile-time option.

Line Breakpoints

When you display code in the Source Window during an interactive session, Source Window Breakpoint control commands become active and breakable lines are displayed with a green circle in the line attribute area (Figure 2-8).

1. To set breakpoints at selected lines of code, select a line with a green circle in the line attribute area.

2. Right-click in the line attribute area, then select Set Breakpoint. A red circle replaces the green circle indicating the breakpoint is enabled. Figure 2-8 shows an active breakpoint at line 12.
3. To select a breakpoint control commands, right-click in the line attribute area, then select Disable Breakpoint, Enable Breakpoint, or Delete Breakpoint.

**Line, Time and Signal Condition Breakpoints**

This section describes how to use the Breakpoints dialog box to set and control breakpoints. Note you can also set line breakpoints in the Breakpoints dialog box. For more information on breakpoint types, see

1. Select **Simulator>Set Breakpoints** to display the Breakpoints dialog box.

2. Click **Define** to display breakpoint definition tabs for creating Line, Time, and Signal breakpoints. Figure 2-9 shows the dialog box.
3. Click **Tips** to get help, then follow the directions on the screen.

After creating breakpoints, you can control them from the upper portion of the dialog box.

For more information on using breakpoints, see Chapter 3, Managing Breakpoints in Interactive Simulation.
Viewing Assertion Data

If your design contains assertions, the Assertion Window displays when you start a simulation or load a database. The Assertion Failure summary tab displays assertion failures and data describing any failures. Figure 2-10 shows the tab with failures listed.

Note: Use the VCS -assert dve command line switch with the -PP option to enable SVA tracing in DVE. If you do not enable SVA tracing, assertion value changes will still be dumped into the VPD file and be visible in the Wave Window, but assertion attempts cannot be traced.

To view an assertion of interest, double click the assertion in the tab. The result is:

- The Hierarchy Browser scrolls to the selected assertion.
- The Variable Pane lists variables in the OCA unit of the selected assertion and the assertions.
- The Assertion tab displays all assertions in the selected unit and information relating to each.
The Wave Window opens displaying the selected assertion with the start and end time of the failure highlighted.

1. To view assertion failure data do one of the following:
   - Drag the scroll bar to the left to view any columns not displayed.
   - To expand the window to show all columns, select a corner or edge of the window and drag it.

2. To customize the display do one or all of the following:
   - Click on a column header to sort the displayed information by the header.
   - Select the right edge of a column in the header and drag it right to make the column wider or to the left to make it smaller or hide the column.
   - Select a column header item and drag and drop it to change the order of the columns.

3. Expand the display of assertions by clicking the icon.

Figure 2-11  Expanded view of assertions in the Assertions tab

Viewing Waveform Information

You can view waveform data in the Wave Window:
• Waveform information as it relates to assertions.
• Waveform information for selected signals of interest.

To display waveform assertion information:

• Double-click an assertion of interest either in the Assertion Failure Summary tab or the Assertions tab.

  The Wave Window appears and displays waveform data related to the selected assertion.

  See Figure 2-12.
To view waveform information for signals in the Wave Window:

1. Open a Wave Window by selecting **Window>New >Wave Window**.
2. Drag and drop a scope of interest from the Hierarchy Browser to the Wave Window.
Figure 2-13  Dragging and dropping signal data into the Wave Window
Viewing Source Code

Notice that when you double-click a scope in the Hierarchy Pane, a signal in the Wave Window, an assertion in the Assertion Window, the Source Window automatically displays the associated HDL or assertion source code.

Figure 2-14  Display of Source Code in the Source Window
Viewing Tabular Data

The List Window displays simulation results in tabular format. For Verilog, the List Window supports nets and register variables. For VHDL, it displays signals and process variables.

To display simulation data in the List Window:

1. Open a List Window by selecting in the toolbar or Window>New >List Window.

2. Drag and drop a scope of interest from a DVE window such as the Hierarchy Browser to the List Window.

   Or

   Right-click and select Add to Lists from the context sensitive menu.

   The data is displayed in the default format.

3. To view signal data, select a signal to highlight the signal values as shown in Figure 2-15.
4. To save the data in ASCII format, select **File>Dump**, select **Tabular List** or **Event Based List**, then enter a name for the file.

**Saving a Session**

Saving a session preserves all settings and data display options. To save your session:

---

Getting Started

2-26
1. Select File>Save Session.

![Image of Save Session dialog box]

2. In the Save Session dialog box, enter a file name for the session.

3. Select **Save only current view** to save only the current Lists window data.

4. Click **Save**.

---

**Loading a Saved Session**

To load a saved session:

1. Select File>Load Session.

2. In the Load Session dialog box, browse to the session and select it from the list of TCL files.
3. Click **Load**.

---

**Closing a Database**

To close a currently open database:

1. Do either of the following
   - Select **File>Close Database**.
   - Click the **Close Database** icon in the Toolbar.

   The Close Database dialog box appears. See Figure 2-16.

   *Figure 2-16  Close Database Confirmation Dialog Box*

   ![Close Database Dialog Box](image)

2. Make sure the correct database is selected, then click **OK**.

   DVE closes the display of the selected database in the Hierarchy Browser.

---

**Exiting DVE**

To exit DVE, select **File>Exit**.
Using the Top Level Window

In DVE, the top level window can contain any other DVE panes and windows. There can be any number of top level windows open at any time. Each has a full menubar and toolbar, though active items depend upon windows or views open in a top level window (for example, Schematic menu commands are active when a Schematic Window is active in a top level window).

This chapter describes how to use the basic components of the DVE Top Level Window as it appears when you open DVE. Other windows, which can be displayed in a top level window, are described in chapters that follow.

• Using the Menu Bar and Toolbar
• Using the Hierarchy Browser
• Using the Data Pane
• Using Source Windows
• Using the Console
Using the Menu Bar and Toolbar

The Menu Bar and Toolbar provide you options for performing standard simulation analysis tasks, such as opening and closing a database, moving the waveform to display different simulation times, or viewing HDL source code.

This section covers the following topics:

• Menu Bar Reference
• Toolbar Reference

Most items in the Menu Bar correspond to icons or text fields in the Toolbar. For example, you can set the simulation time display in the waveform by doing either of the following:

• Select View>Go To Time, then enter a value in the Go To Time dialog box, and click Apply or OK.

• Enter a value in the Time text field on the Toolbar, then press Return on your keyboard.

See Figure 3-1 for an example.
Using the Top Level Window

Figure 3-1  Methods for Setting the Simulation Time

**Menu Bar:**

Select **View>Go To Time**, enter a value in the Go To Time dialog box, then click **Apply** or **OK**.

**Toolbar:**

Enter value in Time text field of the Toolbar, then press the Return key.

**Results:** Waveform display moves to specified simulation time.
Note:

- For complete descriptions of all Menu Bar and Toolbar functions, see "Using the Menu Bar and Toolbar".
- For complete descriptions of setting the simulation time and using the Waveform Window, see Chapter 4, "Using The Wave Window."

---

**Menu Bar Reference**

This section provides an overview of the following Top Level Window menus:

- File Menu
- Edit Menu
- View Menu
- Simulator Menu
- Signal Menu
- Trace Menu
- Window Menu
- Help Menu
## File Menu

The following items comprise the File menu:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Database</td>
<td>Displays the Open Database dialog box, which enables you to select and open simulation database (VCD or VPD) files for post-processing.</td>
</tr>
<tr>
<td>Close Database</td>
<td>Displays the Close Database dialog box, which enables you to close an open simulation database (VPD) file.</td>
</tr>
<tr>
<td>Reload Database</td>
<td>Load the previously opened database.</td>
</tr>
<tr>
<td>Open File</td>
<td>Displays the Open Source File dialog box, which enables you to select and display a source file in the Source Window.</td>
</tr>
<tr>
<td>Close File</td>
<td>Closes the source file displayed in the active Source Window or Window.</td>
</tr>
<tr>
<td>Dump Values</td>
<td>Save current signal data in Tabular List or Event Based List, or entire Memory Contents.</td>
</tr>
<tr>
<td>Execute TCL Script</td>
<td>Displays the Execute TCL Script dialog box, which enables you to select and source a TCL script.</td>
</tr>
<tr>
<td>Load Session</td>
<td>Displays the Load Session Dialog which enables you to Load a saved session.</td>
</tr>
<tr>
<td>Recent Databases</td>
<td>Displays a list recently opened databases to choose from.</td>
</tr>
<tr>
<td>Recent Tcl Scripts</td>
<td>Displays a list recently run scripts to choose from</td>
</tr>
<tr>
<td>Recent Sessions</td>
<td>Displays a list recently opened sessions to choose from</td>
</tr>
<tr>
<td>Save Session</td>
<td>Displays the Save Session Dialog which enables you to Save the current session.</td>
</tr>
<tr>
<td>Close Window</td>
<td>Closes the currently active pane in the Top Level Window.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits DVE.</td>
</tr>
</tbody>
</table>
Edit Menu

The following items comprise the Edit menu:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Allows cutting of selection from any editable window.</td>
</tr>
<tr>
<td>Copy</td>
<td>Allows copying of selection from any DVE window.</td>
</tr>
<tr>
<td>Paste</td>
<td>Allows pasting of cut or copied selection into any editable DVE window or application.</td>
</tr>
<tr>
<td>Delete</td>
<td>Allows deletion of selection from any editable DVE window.</td>
</tr>
<tr>
<td>Expand By Levels</td>
<td>Allows expansion by multiple levels with a single action.</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expands the entire hierarchy at once. There may be a delay getting the hierarchy from the simulation when working interactively.</td>
</tr>
<tr>
<td>Collapse Parent</td>
<td>Collapses the parent of the selected scope.</td>
</tr>
<tr>
<td>Collapse All</td>
<td>Collapses all expanded scopes.</td>
</tr>
<tr>
<td>Synchronize Selection</td>
<td></td>
</tr>
<tr>
<td>Select Scope By Levels</td>
<td>Allows selection of more than 1 level at a time.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all that are visible (does not implicitly expand)</td>
</tr>
<tr>
<td>Find</td>
<td>Finds specified text in a DVE pane or window. Field options vary depending on headers, if any, in the selected pane or window. Multiple Find dialog boxes can be open at any time with each identified by in the dialog box name.</td>
</tr>
<tr>
<td>Find Next</td>
<td>Finds the next occurrence of the search text.</td>
</tr>
<tr>
<td>Find Previous</td>
<td>Finds the previous occurrence of the search text.</td>
</tr>
<tr>
<td>Goto Address</td>
<td>Scrolls to a specified address.</td>
</tr>
<tr>
<td>Search for Signals/Instances</td>
<td>Finds signals and instances in open databases.</td>
</tr>
<tr>
<td>Create Marker</td>
<td>Displays a new marker in the Wave Window.</td>
</tr>
</tbody>
</table>
### View Menu

The following items comprise the **View** menu:

<table>
<thead>
<tr>
<th>Selection Tool</th>
<th>Prepares the cursor for selecting objects (the default cursor).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom In Tool</td>
<td>Prepares the cursor for zooming in. The cursor becomes a magnifying glass. Drag a bounding box around the area to enlarge.</td>
</tr>
<tr>
<td>Zoom Out Tool</td>
<td>Prepares the cursor for zooming out. The cursor becomes a magnifying glass. Drag a small box to zoom out by a large amount, or a large box to zoom out by a small amount.</td>
</tr>
<tr>
<td>Pan Tool</td>
<td>Prepares the cursor for panning the window view. The cursor becomes a hand shape. Point and drag to pan the view.</td>
</tr>
<tr>
<td>Zoom Full</td>
<td>Zoom to entire design.</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Zooms in 2x.</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Zooms out 2x.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Markers . . .</th>
<th>Displays the Markers dialog box for managing markers.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto Marker</td>
<td>Scrolls the Wave display to the specified marker.</td>
</tr>
<tr>
<td>Delete Marker</td>
<td>Removes the specified marker.</td>
</tr>
<tr>
<td>Create Reference Marker</td>
<td>Displays a reference marker at the specified location.</td>
</tr>
<tr>
<td>Show Marker Values</td>
<td>Displays Absolute, Adjacent, or Relative values for signals at a selected marker.</td>
</tr>
<tr>
<td>Preferences</td>
<td>Opens the Applications Preferences dialog box to allow customization of the display settings on a global or window basis.</td>
</tr>
<tr>
<td><strong>Zoom Fit Selection</strong></td>
<td>Zooms to area selected with the Selection Tool.</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td><strong>Zoom Fit Highlight</strong></td>
<td>Zooms to highlighted area.</td>
</tr>
<tr>
<td><strong>Pan To Selection</strong></td>
<td>Pans to area selected with the Selection Tool.</td>
</tr>
<tr>
<td><strong>Pan To Highlight</strong></td>
<td>Pans to highlighted area.</td>
</tr>
<tr>
<td><strong>Back in Zoom and Pan History</strong></td>
<td>Returns to previous zoom or pan setting.</td>
</tr>
<tr>
<td><strong>Forward in Zoom and Pan History</strong></td>
<td>Goes to next zoom or pan setting.</td>
</tr>
<tr>
<td><strong>Named Zoom and Pan Settings</strong></td>
<td>Allows setting zoom parameters.</td>
</tr>
<tr>
<td><strong>Zoom to Cursors</strong></td>
<td>Zooms wave display to cursors C1 and C2.</td>
</tr>
<tr>
<td><strong>Zoom to Time Range</strong></td>
<td>Zooms to specified time range.</td>
</tr>
<tr>
<td><strong>Set Time Scale</strong></td>
<td>Opens Set Time Units and Scale dialog box for setting display units and precision.</td>
</tr>
<tr>
<td><strong>List Window Time Range</strong></td>
<td>Allows setting upper and lower time window values in the List Window.</td>
</tr>
<tr>
<td><strong>Delta Cycle</strong></td>
<td><strong>Expand Time</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Collapse Time</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Collapse All</strong></td>
</tr>
<tr>
<td><strong>Go to Beginning</strong></td>
<td>Moves the display of the Wave Window(s) to the beginning of the simulation.</td>
</tr>
<tr>
<td><strong>Go to End</strong></td>
<td>Moves the display of the Wave Window(s) to the end of the simulation.</td>
</tr>
<tr>
<td><strong>Go to Time</strong></td>
<td>Displays the Go To Time dialog box, where you specify a simulation time. When you click <strong>Apply</strong>, the C1 cursor (current time) moves to the center of the wave window and makes the new time the current time.</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Filter Assertion</strong></td>
<td>Displays the Filter dialog box, which enables filtering assertion data.</td>
</tr>
<tr>
<td><strong>Increase Row Height</strong></td>
<td>Makes the height of the displayed data greater.</td>
</tr>
<tr>
<td><strong>Decrease Row Height</strong></td>
<td>Makes the height of the displayed data lesser.</td>
</tr>
<tr>
<td><strong>Ports and Signals Filter</strong></td>
<td><strong>Port In</strong> Toggles display of input ports.</td>
</tr>
<tr>
<td></td>
<td><strong>Port Out</strong> Toggles display of output ports.</td>
</tr>
<tr>
<td></td>
<td><strong>Port Inout</strong> Toggles display of inout ports.</td>
</tr>
<tr>
<td></td>
<td><strong>Port Buffer</strong> Toggles display of port buffers.</td>
</tr>
<tr>
<td></td>
<td><strong>Signal</strong> Toggles display of signals.</td>
</tr>
<tr>
<td></td>
<td><strong>Port Linkage</strong> Toggles display of VHDL port linkage.</td>
</tr>
<tr>
<td><strong>Panes</strong></td>
<td><strong>Console</strong> Displays Console Pane in active window.</td>
</tr>
<tr>
<td></td>
<td><strong>Hierarchy</strong> Displays Hierarchy Pane in active window.</td>
</tr>
<tr>
<td></td>
<td><strong>Data</strong> Displays Data Pane in active window.</td>
</tr>
<tr>
<td><strong>Toolbars &gt;</strong></td>
<td><strong>Time Operations</strong> Toggles the display of the Time Operations toolbar buttons.</td>
</tr>
<tr>
<td></td>
<td><strong>File</strong> Toggles the display of the File toolbar buttons.</td>
</tr>
<tr>
<td></td>
<td><strong>Edit</strong> Toggles the display of the Edit toolbar buttons.</td>
</tr>
</tbody>
</table>
### Simulator Menu

The following items comprise the **Simulator** menu

<table>
<thead>
<tr>
<th><strong>Setup...</strong></th>
<th>Displays the Simulation Setup dialog box, which allows you to set the simulator type, executable location and arguments for running an interactive simulation.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start</strong></td>
<td>Starts or terminates and restarts an interactive simulation with the current simulation setup. See Simulate&gt;Setup...</td>
</tr>
<tr>
<td><strong>Rebuild and Start</strong></td>
<td>Recompiles the design and starts simulation.</td>
</tr>
<tr>
<td><strong>Stop</strong></td>
<td>Stops a running simulator.</td>
</tr>
<tr>
<td><strong>Continue</strong></td>
<td>Continues running a simulator that was stopped.</td>
</tr>
<tr>
<td><strong>Step</strong></td>
<td>Runs the simulator to the next executable line, stepping into functions, tasks, etc.</td>
</tr>
<tr>
<td><strong>Next</strong></td>
<td>Runs the simulator to the next executable line, stepping over functions, tasks, etc.</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Delete Breakpoint At</strong></td>
<td>Allows deletion of a specified breakpoint.</td>
</tr>
<tr>
<td><strong>Delete All Breakpoints</strong></td>
<td>Removes all breakpoints.</td>
</tr>
<tr>
<td><strong>Breakpoints</strong></td>
<td>Displays the Breakpoints dialog that allows viewing, creating, editing, enabling, disabling, and deleting breakpoints.</td>
</tr>
<tr>
<td><strong>Save State</strong></td>
<td>Saves the current state for later display.</td>
</tr>
<tr>
<td><strong>Restore State</strong></td>
<td>Redisplays a saved state.</td>
</tr>
<tr>
<td><strong>Terminate</strong></td>
<td>Finishes simulation and terminates the interactive simulator.</td>
</tr>
<tr>
<td><strong>Capture Delta Cycle Values</strong></td>
<td>Saves delta cycle values.</td>
</tr>
<tr>
<td><strong>Set Step Time...</strong></td>
<td>Displays the Set Continue Time dialog box, which allows you to set the time duration for continuing simulation for a specified time. See Continue.</td>
</tr>
<tr>
<td><strong>Periodic Waveform Update Interval</strong></td>
<td>Allows setting of the value interval at which to update display of waveforms.</td>
</tr>
</tbody>
</table>

## Signal Menu

The following items comprise the **Signal** menu:

<table>
<thead>
<tr>
<th><strong>Signal Groups</strong></th>
<th>Opens the Signal Groups dialog box, which allows you to review and edit signal groups.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Create Signal Groups</strong></td>
<td>Creates a signal group from selected signals.</td>
</tr>
<tr>
<td><strong>Display Signal Groups</strong></td>
<td>Adds selected signal groups to display pane.</td>
</tr>
</tbody>
</table>

Using the Top Level Window

3-11
<table>
<thead>
<tr>
<th><strong>Display All Signal Groups</strong></th>
<th>Adds all signal groups to display pane.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add to Waves</strong></td>
<td>Displays the selected signals in the Waves Window</td>
</tr>
<tr>
<td><strong>Add to Lists</strong></td>
<td>Displays the selected signals in the Lists Window.</td>
</tr>
<tr>
<td><strong>Show Memory</strong></td>
<td>Displays contents of memory variable.</td>
</tr>
<tr>
<td><strong>Create Bus</strong></td>
<td>Displays the Bus Builder dialog box for creating buses.</td>
</tr>
<tr>
<td><strong>Edit Bus</strong></td>
<td>Displays the Bus Builder dialog box for editing the selected bus.</td>
</tr>
<tr>
<td><strong>Set Expression</strong></td>
<td>Displays the expression dialog box for using signals to create expressions.</td>
</tr>
<tr>
<td><strong>Set Search Constant</strong></td>
<td>Allows selection of a constant search criterion.</td>
</tr>
<tr>
<td><strong>Search Backward</strong></td>
<td>Finds the previous specified search constant in the design.</td>
</tr>
<tr>
<td><strong>Search Forward</strong></td>
<td>Finds the next specified search constant in the design.</td>
</tr>
<tr>
<td><strong>Compare</strong></td>
<td>Opens Waveform Compare dialog box for the selection of signals, scopes, or buses to compare.</td>
</tr>
<tr>
<td><strong>Show Comparison Info</strong></td>
<td>Displays the results of the signal comparison.</td>
</tr>
<tr>
<td><strong>Shift Time</strong></td>
<td>Displays the Shift Signal dialog for specifying time offset for shifting specified signals.</td>
</tr>
<tr>
<td><strong>Set Radix</strong></td>
<td>Allows the selection of radix value.</td>
</tr>
<tr>
<td><strong>Edit User-Defined Radices</strong></td>
<td>Displays the Edit User-Defined Radix dialog box for creating, editing, and deleting radices.</td>
</tr>
</tbody>
</table>
Using the Top Level Window

Scope Menu

The following items comprise the **Scope** menu:

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Properties</strong></td>
<td>Displays the Signal Properties dialog box which displays data on the selected signal.</td>
</tr>
<tr>
<td><strong>Show Source</strong></td>
<td>Displays source code for the selected scope in the Source Window.</td>
</tr>
<tr>
<td><strong>Show Schematic</strong></td>
<td>Displays design in the Schematic Window.</td>
</tr>
<tr>
<td><strong>Show Path Schematic</strong></td>
<td>Displays Path Schematic Window with selected paths.</td>
</tr>
<tr>
<td><strong>Move Up to Parent</strong></td>
<td>Displays to the parent source code of the active scope.</td>
</tr>
<tr>
<td><strong>Move Down to Definition</strong></td>
<td>Displays the definition source code of the selected text in the active Source Window.</td>
</tr>
<tr>
<td><strong>Back</strong></td>
<td>Moves back in list of scopes or schematics.</td>
</tr>
<tr>
<td><strong>Forward</strong></td>
<td>Moves forward in list of scopes or schematics.</td>
</tr>
<tr>
<td><strong>Show &gt; Current Scope</strong></td>
<td>Scrolls Source Window display so that the first line of the active scope is visible.</td>
</tr>
<tr>
<td><strong>Assertion</strong></td>
<td>Scrolls Source Window display so that the first line of the active assertion unit is displayed.</td>
</tr>
<tr>
<td><strong>Unit Binding</strong></td>
<td>Scrolls Source Window display so that the first line of the active unit binding is displayed.</td>
</tr>
<tr>
<td><strong>Entity</strong></td>
<td>Displays the entity source code of the active VHDL architecture in the Source Window.</td>
</tr>
</tbody>
</table>
Trace Menu

The following item comprises the Trace menu:

<table>
<thead>
<tr>
<th>Trace Assertion</th>
<th>Displays data for the selected assertion in the Wave Window.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assertion Attempts</td>
<td>Displays the Trace Assertion Attempts dialog for displaying attempt trace information in the Wave Window.</td>
</tr>
<tr>
<td>Show Drivers and Loads</td>
<td>Displays data pertaining to signal drivers and loads.</td>
</tr>
<tr>
<td>Trace Drivers</td>
<td>Displays data pertaining to signal drivers.</td>
</tr>
<tr>
<td>Trace Loads</td>
<td>Displays data pertaining to signal loads.</td>
</tr>
<tr>
<td>Drivers/Loads</td>
<td>Displays the last or following values of drivers and loads for the selected signal in the current instance</td>
</tr>
<tr>
<td>Previous/Next In This Instance</td>
<td></td>
</tr>
<tr>
<td>In Previous/Next Instance</td>
<td>Displays the values of drivers and loads for the selected signal in the last or following instance.</td>
</tr>
<tr>
<td>---------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Repeat Last Trace</td>
<td>Repeats previously performed trace.</td>
</tr>
<tr>
<td>Set Current Color</td>
<td>Allows setting of display color for the selected signal.</td>
</tr>
<tr>
<td>Highlight</td>
<td>Allows manual tracing of selected signals in Design and Path Schematic windows by highlighting of the selected signals based on specified color assignments.</td>
</tr>
<tr>
<td>Clear Selected/ Clear /Clear All</td>
<td>Clears current, by color, or all signals manually traced using the Highlight command.</td>
</tr>
<tr>
<td>Follow Signal</td>
<td>Highlights the currently selected signal in the Path Schematic window and traces it across boundaries.</td>
</tr>
<tr>
<td>Stop Following</td>
<td>Turns off highlighting of a signal performed with the Follow Signal Command.</td>
</tr>
<tr>
<td>Trace X</td>
<td></td>
</tr>
</tbody>
</table>

**Window Menu**

The following items comprise the **Window** menu:

<p>| New | Console Pane | Opens a new Console Pane for entering TCL commands, viewing command logs and assertion first failure results summary, if one is not already open. |</p>
<table>
<thead>
<tr>
<th>Hierarchy Pane</th>
<th>Opens a new Hierarchy Browser for traversing design and verification hierarchy, if one is not already open.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assertion Window</td>
<td>Opens an Assertion window, if one is not already open.</td>
</tr>
<tr>
<td>List Window</td>
<td>Opens a new List Window or viewing signal waveforms in tabular format and analyzing assertion results with relevant signal waveforms, if one is not already open.</td>
</tr>
<tr>
<td>Source Window</td>
<td>Opens a new Source Window outside of the Top Level Window for viewing source files.</td>
</tr>
<tr>
<td>Wave Window</td>
<td>Opens a new Wave Window for viewing signal waveforms and analyzing assertion results with relevant signal waveforms.</td>
</tr>
<tr>
<td>Schematic Window</td>
<td>Opens a Schematic Window.</td>
</tr>
<tr>
<td>Path Schematic Window</td>
<td>Opens a Path Schematic Window.</td>
</tr>
<tr>
<td>Panes</td>
<td>Displays the selected pane in the active top-level window.</td>
</tr>
<tr>
<td>New Assertion Window</td>
<td>Opens a new Assertion window.</td>
</tr>
<tr>
<td>New List Window</td>
<td>Opens a new List Window for viewing signal waveforms in tabular format and analyzing assertion results with relevant signal waveforms, if one is not already open.</td>
</tr>
<tr>
<td>New Wave Window</td>
<td>Opens a new Wave Window for viewing signal waveforms and analyzing assertion results with relevant signal waveforms.</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Cascade</td>
<td>Arranges all open workspace windows so they are displayed in a cascade pattern.</td>
</tr>
<tr>
<td>Tile</td>
<td>Arranges all open workspace windows so they are displayed in a horizontal tile pattern.</td>
</tr>
<tr>
<td>Dock &gt;</td>
<td></td>
</tr>
<tr>
<td>Left</td>
<td>Docks the selected window to the left wall of the Top Level Window.</td>
</tr>
<tr>
<td>Right</td>
<td>Docks the selected window to the right wall of the Top Level Window.</td>
</tr>
<tr>
<td>Top</td>
<td>Docks the selected window to the top wall of the Top Level Window.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Docks the selected window to the bottom wall of the Top Level Window.</td>
</tr>
<tr>
<td>Undock</td>
<td>Undocks the selected window from the Top Level Window.</td>
</tr>
<tr>
<td>Set Default Wave Window</td>
<td>If more than one Wave Window is being used, sets the most recently active one as the default when context sensitive menus are used.</td>
</tr>
<tr>
<td>Set Default List Window</td>
<td>If more than one List Window is being used, sets the most recently active one as the default when context sensitive menus are used.</td>
</tr>
</tbody>
</table>

**Help Menu**

The following items comprise the **Help** menu:

<table>
<thead>
<tr>
<th>DVE Help</th>
<th>Opens Acrobat Reader with the DVE documentation.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Release Notes</td>
<td>Opens the current release notes in a Source Window.</td>
</tr>
<tr>
<td>A Quick Start Example</td>
<td>Loads an example design.</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>About</td>
<td>Displays DVE version and copyright information.</td>
</tr>
</tbody>
</table>
Keyboard Shortcuts

File Command Shortcuts

Ctrl+O          open database
Ctrl+W          close window

Edit Command Shortcuts

Ctrl+X          cut
Ctrl+C          copy
Ctrl+V          paste
DEL             delete
Ctrl+Y          synchronize selection
Ctrl+A          select all
Ctrl+F3         find
F3              find next
Shift+F3        find prev
Ctrl+G          goto address

View Command Shortcuts

ESC              selection tool
=                zoom in tool
-                zoom out tool
Ctrl+F          zoom full
Using the Top Level Window

Simulator Command Shortcuts

- Ctrl+F5: start
- F5: continue
- F11: step
- F10: next

Signal Command Shortcuts

- Ctrl+4: add to waves
- Ctrl+5: add to lists
- Ctrl+6: show memory
- Shift+F4, <: search backward
- F4, >: search forward
Scope Command Shortcuts

Ctrl+1 show source
Ctrl+2 show schematic
Ctrl+3 show path schematic
Backspace (no text in menu) move up
Enter (no text in menu) move down

Trace Command Shortcuts

Ctrl+D trace drivers
Ctrl+L trace loads
Ctrl+E highlight selected
Ctrl+Shift+M clear selected
Ctrl+M clear all
CTrl+N next color

Help Command Shortcuts

F1 help
F2 quick start example
### Toolbar Reference

This section describes all Toolbar text fields, menus, and icons.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Time" /></td>
<td>Displays the current time of the C1 cursor. Set the current time by entering a new time in this field.</td>
</tr>
<tr>
<td><img src="image" alt="x 100ps" /></td>
<td>Displays the time units for displaying simulation data. Select View &gt; Set Time Scale to set time units and precision.</td>
</tr>
<tr>
<td><img src="image" alt="Open Database or File" /></td>
<td>Displays the Open Database or Open File dialog box, depending on the DVE window displayed, and enables you to select and open a VPD file.</td>
</tr>
<tr>
<td><img src="image" alt="Close Database" /></td>
<td>Displays the Close File dialog box, which enables you to close an open VPD file.</td>
</tr>
<tr>
<td><img src="image" alt="Execute Tcl Script" /></td>
<td>Displays the Tcl Script dialog box, which enables you to select and source a Tcl script.</td>
</tr>
<tr>
<td><img src="image" alt="Close Window" /></td>
<td>Closes the currently active window.</td>
</tr>
<tr>
<td><img src="image" alt="Continue" /></td>
<td>Continues running a simulator that was stopped.</td>
</tr>
<tr>
<td><img src="image" alt="Stop" /></td>
<td>Stops a running simulator.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="Image1" alt="Icon" /></td>
<td>Runs the simulator to the next executable line, stepping into functions, tasks, etc.</td>
</tr>
<tr>
<td><img src="Image2" alt="Icon" /></td>
<td>Runs the simulator to the next executable line, stepping over functions, tasks, etc.</td>
</tr>
<tr>
<td><img src="Image3" alt="Icon" /></td>
<td>Gets signal values for the active scope in the source pane from the simulation database.</td>
</tr>
<tr>
<td><img src="Image4" alt="Icon" /></td>
<td>Displays the active scope signal values at the current time in the source pane.</td>
</tr>
<tr>
<td><img src="Image5" alt="Icon" /></td>
<td>Sets a line breakpoint on the selected line in the Source window. Line stepping and simulators will stop on execution of this line.</td>
</tr>
<tr>
<td><img src="Image6" alt="Icon" /></td>
<td>Clears a line breakpoint from the selected line in the Source window.</td>
</tr>
<tr>
<td><img src="Image7" alt="Icon" /></td>
<td>Click to begin an interactive simulation session.</td>
</tr>
<tr>
<td><img src="Image8" alt="Icon" /></td>
<td>When the simulation is running, this icon is activated. Click to stop the simulation.</td>
</tr>
<tr>
<td><img src="Image9" alt="Icon" /></td>
<td>Continue until the next valid breakpoint (monitor), user interrupt, or the end of simulation.</td>
</tr>
</tbody>
</table>

Using the Top Level Window

3-23
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Step icon" /></td>
<td>Move the simulation forward in time as set by the Simulator&gt;Set Step Time command. <code>step</code> will step into task and functions.</td>
</tr>
<tr>
<td><img src="image" alt="Next icon" /></td>
<td>For VHDL code, next steps over tasks and functions.</td>
</tr>
<tr>
<td><img src="image" alt="Annotate Values icon" /></td>
<td>Displays the active scope signal values at the current time in the Source Window.</td>
</tr>
<tr>
<td><img src="image" alt="List Window icon" /></td>
<td>Opens a new List Window</td>
</tr>
<tr>
<td><img src="image" alt="Source Window icon" /></td>
<td>Opens a new Source Window.</td>
</tr>
<tr>
<td><img src="image" alt="Wave Window icon" /></td>
<td>Opens a new Wave Window.</td>
</tr>
<tr>
<td><img src="image" alt="Schematic Window icon" /></td>
<td>Opens a new Schematic Window.</td>
</tr>
<tr>
<td><img src="image" alt="Path Schematic Window icon" /></td>
<td>Opens a new Path Schematic Window.</td>
</tr>
</tbody>
</table>
Managing DVE Windows

A DVE top-level window is a frame for displaying design and debug data. A top-level can contain many any number of DVE windows and panes. You can choose to display data in one or many DVE windows and panes by setting defaults (see the previous section), using the status bar window controls, or docking and undocking windows as you work.

Displaying Data in a New Top-Level Window

A red circle in the status bar window control icon in the lower right corner indicates a new window of that kind will be opened in the currently active top-level window.

To open a window in a new top-level window, click the icon representing the window you want to display. The circle is removed indicating the next time you open a window of that type, it will open in a new top-level window.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="DVE Help Icon" /></td>
<td>Click button to activate the help cursor (?) then click on screen item to display help for the selected item.</td>
</tr>
<tr>
<td><img src="image" alt="Quick Start Example Icon" /></td>
<td>Runs an example DVE session.</td>
</tr>
</tbody>
</table>

Using the Top Level Window
Docking and Undocking Windows and Panes

You can use the Windows menu to dock and undock windows and panes.

- Select **Windows > Dock in New Row**, then select the row position to dock the currently active window.
- Select **Windows > Dock in New Column**, then select the column position to dock the currently active window.
- Select **Undock** to detach the currently active window or pane.

Setting Display Preferences

You can set preferences to customize the display of DVE windows display in the Hierarchy and Data panes (as well as in the Waves Window Wave Signal Group panes).

To customize the display:

1. In the Top Level Window, select **Edit > Preferences**.
   - The Application Preferences dialog box displays the Global Settings category.
2. In the Categories pane, select a setting to customize.
3. Select settings as follows:

- Global Settings – Select settings to set the general appearance of DVE windows, such as font size.

- Debug Settings – Signal compare parameters, value transition, exit dialog and assertion window docking defaults, and first frame target setup options.

- Hierarchy Browser – Set the appearance and initial filter states.

- Data Pane – Appearance parameters, signal sorting, signal levels to display, and scroll bar condition.

- Source Window – Data and annotation loading options, line wrap, line number display, tab width, default editor, and automatic reload of changed source code.

- Schematic Window – Line colors for schematic objects in Schematic and Path Schematic windows.
- Waveform Window – Appearance parameters, signal levels to display, and marker value display settings.

- List Window – Grid display, signal name truncation, signal levels to display, and column spacing settings.

- Coverage Settings – Allows setting of weights for display of line, condition, toggle, FSM, and cover metrics.

- Coverage Colors – Coverage range and color settings for coverage display.

4. Set the font and size of the monospaces font used in the console, reports, and other DVE output.

5. Use the up and down arrows to set the maximum number of log lines displayed.

6. Select and deselect the check boxes to set other global preferences.

7. Click OK to save your selections and close the dialog box.

Using the Hierarchy Browser

The Hierarchy Browser enables you to navigate within the design hierarchy, and locate and select scopes used for viewing variables, assertions, and waveforms in other DVE windows.

This section describes the basic techniques for using the Hierarchy Browser in a simulation analysis.

The following topics are covered:

- Navigating the Hierarchy
- Scope Types and Icons
- Using the Data Pane
- Rearranging Hierarchy Information

Figure 3-3 shows the appearance of the Hierarchy Browser loaded with a database.

**Figure 3-3  Hierarchy Browser**

<table>
<thead>
<tr>
<th>Scope Type</th>
<th>Object Definition Name (in Parentheses)</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMPONENTS (COMPONENTS)</td>
<td>Package(Event)</td>
<td></td>
</tr>
<tr>
<td>TEST (TEST:TESTARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>TEST_P0 (TEST_P0)</td>
<td>Process(Event)</td>
<td></td>
</tr>
<tr>
<td>I1 (MONITOR:MONITORARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>START_VALUES (START_VAL)</td>
<td>Process(Event)</td>
<td></td>
</tr>
<tr>
<td>GLITCHY_BUF2 (MYBUF1:M)</td>
<td>Entity(Cycle)</td>
<td></td>
</tr>
<tr>
<td>GLITCHY_BUF1 (MYBUF1:M)</td>
<td>Entity(Cycle)</td>
<td></td>
</tr>
<tr>
<td>P1 (_P1)</td>
<td>Process(Event)</td>
<td></td>
</tr>
<tr>
<td>P0 (_P0)</td>
<td>Process(Event)</td>
<td></td>
</tr>
<tr>
<td>RISC1 (CPU:CPUARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>ALU1 (ALU:ALUARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>P4 (_P4)</td>
<td>Process(Event)</td>
<td></td>
</tr>
<tr>
<td>CLK'S (CLOCKS:CLOCKARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>PGMCTR (COUNTER:COUNTE)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>INSTDEC (DECODER:DECODE)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>MEM1 (MEM:MEMARCH)</td>
<td>Entity(Event)</td>
<td></td>
</tr>
<tr>
<td>REG2 (REG:REGARCH)</td>
<td>Entity(Cycle)</td>
<td></td>
</tr>
</tbody>
</table>
Navigating the Hierarchy

This section describes the basic techniques for navigating the Hierarchy Browser.

When the Hierarchy Browser first appears, the design tree is not fully expanded.

To expand the view of scopes in the hierarchy:

• Click on a ▶ icon, located to the left of a scope.

  The hierarchy tree expands. Continue to click the ▶ icons to fully expand the hierarchy tree. See Figure 3-4.
To collapse a portion of the hierarchy tree:

- Click on the icon, located to the left of a scope.

The selected scope, and its descendents within the hierarchy tree, collapses. Continue to click the icons to fully collapse the hierarchy tree. See Figure 3-5.
To fully collapse a hierarchy tree with single click:

- Click the icon corresponding to the root of the design. See Figure 3-6.
Figure 3-6  Collapsing entire design hierarchy

Click root to collapse hierarchy

Entire hierarchy collapses
## Scope Types and Icons

DVE displays a wide variety of scope types in the Hierarchy Browser. Each scope type is represented by a specific icon.

The following table provides an overview of the various scope types and their corresponding icons, as displayed in the Hierarchy Browser.

<table>
<thead>
<tr>
<th>Scope Type</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Root</td>
<td>![folder_icon]</td>
<td>Contains the top of all design hierarchy. Expand the Design Root to see the design.</td>
</tr>
<tr>
<td>Verilog Module</td>
<td>![module_icon]</td>
<td>Denotes an instance of a Verilog module. Verilog instances are listed as instance name (module name).</td>
</tr>
<tr>
<td>Verilog Task</td>
<td>![task_icon]</td>
<td>Denotes a Verilog task.</td>
</tr>
<tr>
<td>Verilog Function</td>
<td>![function_icon]</td>
<td>Denotes a Verilog task.</td>
</tr>
<tr>
<td>Verilog Named Begin</td>
<td>![named_icon]</td>
<td></td>
</tr>
<tr>
<td>Verilog Named Fork</td>
<td>![fork_icon]</td>
<td></td>
</tr>
<tr>
<td>Assertion Unit</td>
<td>![assertion_icon]</td>
<td>Denotes an assertion unit. In hierarchy, an assertion unit is listed below the instance to which it is bound. Assertions are listed as instance name (unit name).</td>
</tr>
<tr>
<td>Scope Type</td>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>VHDL Cycle Instance</td>
<td>![icon]</td>
<td>Denotes an instance of a VHDL Entity that was simulated in cycle mode. VHDL instances are listed as instance name (Entity:Architecture).</td>
</tr>
<tr>
<td>VHDL Event Instance</td>
<td>![icon]</td>
<td>Denotes an instance of a VHDL Entity that was simulated in event mode. VHDL instances are listed as instance name (Entity:Architecture).</td>
</tr>
<tr>
<td>VHDL Package</td>
<td>![icon]</td>
<td>Denotes a VHDL package.</td>
</tr>
<tr>
<td>VHDL Procedure</td>
<td>![icon]</td>
<td>Denotes a VHDL procedure.</td>
</tr>
<tr>
<td>VHDL Function</td>
<td>![icon]</td>
<td>Denotes a VHDL function.</td>
</tr>
<tr>
<td>VHDL Process</td>
<td>![icon]</td>
<td>Denotes a VHDL process.</td>
</tr>
<tr>
<td>VHDL Block</td>
<td>![icon]</td>
<td></td>
</tr>
<tr>
<td>VHDL Generic</td>
<td>![icon]</td>
<td></td>
</tr>
<tr>
<td>SystemC Instance</td>
<td>![icon]</td>
<td>Denotes an instance of a SystemC entity.</td>
</tr>
<tr>
<td>SystemC Process</td>
<td>![icon]</td>
<td>Denotes a SystemC process.</td>
</tr>
</tbody>
</table>
Using the Data Pane

DVE displays simulation analysis data corresponding to the contents of the scope you select in the Hierarchy Browser.

To select a scope in the Hierarchy Browser:

- Click on the scope name to select the scope and populate the Data pane.
- Double-click anywhere on the name of the scope to select the scope and populate the Data pane and the Source Window.

See Figure 3-7.

To view source code for a signal in the Data Pane, select a signal, then select **Source > Show Source**.

The Source Window displays the source code for the selected signal.
Select a scope in the Hierarchy Browser to populate the Data Pane. The Data Pane displays signals in the selected scope. Select a signal in the Data Pane. Select Source > Show Source. The Data Pane displays signals in the selected scope.

The Source Window displays the source code for the signal.
Rearranging Hierarchy Information

You can sort the hierarchy column or rearrange the order in which the column headings appear in the Hierarchy Browser.

*Figure 3-8  Moving a column heading*

Click and hold down your mouse on column heading you want to move. Drag object to new location and release mouse button. Column heading move to new location.

Click the triangle to reverse the sort order of the hierarchy column.
Viewing Multiple Designs

You can load any number of VCD or VPD files and one interactive simulation at any time and move among the designs in the Hierarchy Browser. When you open a second design, a navigation box with a pulldown menu displays at the top of the Hierarchy Browser. To move among the designs, click the arrow and select a design to display.

Figure 3-9  Navigating among multiple designs
Using Context Sensitive Menus

In any window, right-click to display a context-sensitive menu, then select a command. The Hierarchy Browser context sensitive menu is shown below:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copy selected text.</td>
</tr>
<tr>
<td>Add to Waves</td>
<td>Display the selected signal or signals in the Wave Window.</td>
</tr>
<tr>
<td>Add to Lists</td>
<td>Display the selected signal or signals in the List Window.</td>
</tr>
<tr>
<td>Show Source</td>
<td>Display source code in the Source Window for the selected scope.</td>
</tr>
<tr>
<td>Expand By Levels</td>
<td>Allows expansion by multiple levels with a single action.</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expands the entire hierarchy at once. There may be a delay getting the hierarchy from the simulation when working interactively.</td>
</tr>
<tr>
<td>Collapse</td>
<td>Collapses the selected scope.</td>
</tr>
<tr>
<td>Collapse All</td>
<td>Collapses all expanded scopes.</td>
</tr>
<tr>
<td>Select Scope By Levels</td>
<td>Allows user to select more than 1 level at a time.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all that are visible (does not implicitly expand)</td>
</tr>
</tbody>
</table>
Using Source Windows

Source Windows and Windows display HDL or assertion source code corresponding to your design. You can set the number of panes in the Top Level Window or open as many Source Windows as needed to perform your analysis by selecting View>Source Window.

This section covers the following topics:

- Loading Source Code
- Working with the Source Window
- Using the Source Code Area
- Editing Source Code

Figure 3-10 show the various types of data you can load and display in a Source Window.

Figure 3-10  Example Source Windows

```vhdl
architecture TESTARCH of test is
begin
architecture TESTARCH of test is
begin
    signal reset_req : std_logic;
    component dump
        port (aout : out std_logic);
    end component;
    component cpu
        port (reset_req : in std_logic);
    end component;
    begin
        RISC1 : cpu port map(reset_req);
        I1 : dump;
        TEST_P0 : process
        begin
            \n```
Loading Source Code

This section covers the following topics

- Loading a Source Window from the Hierarchy Browser
- Loading a Source Window from the Assertion Window

Loading a Source Window from the Hierarchy Browser

To load HDL data into a Source Window or from the Hierarchy Browser:

1. Make sure a database is currently loaded in the Hierarchy Browser.

2. In the Hierarchy Browser, do either of the following:

   - Select a scope, then select **Source > Show Source**.
   - Double-click on a scope icon.

   The Source Window loads the data corresponding to the selected scope. See Figure 3-11.
Using the Top Level Window

Figure 3-11  Loading the Source Window

- Drag and drop a scope to the Source Window or Window.

Loading a Source Window from the Assertion Window

To load assertion code into a Source Window via the Assertion Window:

Double-click a scope in the Hierarchy Browser

Corresponding data loads into the Source Window
1. Make sure the Assertion Window is loaded with data. If your design contains assertions, the Assertion Window loads results when you open the simulation database.

2. Do either of the following:
   - Select an assertion in either tab, then select Source > Show Source.
   - In the Assertion Failure Summary tab or the Assertions tab, double-click the variable or assertion you want to display in the Source Window.
   - In the Assertion Failure Summary tab or the Assertion tab, drag and drop the item to the Source Window or Window.

DVE loads and displays the source file.
Double-click an assertion in the tab

or

Select the assertion file in the Open Source File dialog box

The corresponding data appears in the Source Window
Displaying Source Code from a File

To use the Menu bar or Toolbar to load a specific HDL source file into the Source Window:

1. Select **Window>New Source Window**.
2. Select **File > Open File**.
   
The Open HDL File Dialog box appears.
3. Select the name of the HDL file you want to display, then click **Open**.
   
   DVE loads and displays the selected HDL source file.

---

Using the mouse in the Source Window

The table below describes mouse action in the Source Window.

<table>
<thead>
<tr>
<th>Mouse Action</th>
<th>Command Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click-left</td>
<td>Deselect the current selection and select a signal or an instance</td>
</tr>
<tr>
<td>Drag-left</td>
<td>Area select for multiple selection</td>
</tr>
<tr>
<td>Click on the line number</td>
<td>Select the whole line</td>
</tr>
<tr>
<td>Double-click on a signal name</td>
<td>Trace the signal's drivers</td>
</tr>
<tr>
<td>Double-click on an instance</td>
<td>Push down into the instance's definition module</td>
</tr>
<tr>
<td>Double-click on a module name</td>
<td>Display the upper hierarchy and locate the module's calling statement</td>
</tr>
<tr>
<td>Double-click on an architecture</td>
<td>Jump to the entity definition of selected entity_name or jump to instance definition of the entity</td>
</tr>
<tr>
<td>Double-click on an entity (After double-clicking on an architecture)</td>
<td>Jump to the architecture that was double-clicked previously</td>
</tr>
<tr>
<td>Right-click on a signal name</td>
<td>Display a context-sensitive menu</td>
</tr>
</tbody>
</table>
Working with the Source Window

Use the Source Window to

• Expand and collapse code.
• Display line attributes,
• View and set line breakpoints for interactive simulation.
• Examine code while debugging.
• Drop code into other DVE windows.
• Launch a text editor to revise code.

Display Source Code Commands

When working with the Source Window, you right-click in the code to display menus containing commands that control most functions. Figure 3-16 shows the Source Window menus.
Expanding and Collapsing Source Code View

To expand or collapse the source code view do one of the following:

Click 

in the Line Attribute area, or right-click and select **Expand Source** to view code that is folded.

Click 

in the Line Attribute area, or right-click and select **Collapse Source** to hide code.
Graphically Viewing Source Code

To graphically view source code,

1. Drag your mouse across the text you want to select or double-click on a token (word).

   DVE highlights the selected text.

2. Holding the left mouse button down, drag the code into the right pane of a DVE window, the release the mouse button to drop the code into the window.

   The selected code displays graphically.

```
logic [0:WIDTH] outpl, logic clk;

clock posedge clk {
  event E1 : (outpl == (inp1 || inp2));
}
assert A1 : check(E1);
endunit
```

Drag and drop selected code to a DVE window (Wave Window is shown).

Editing Source Code

Use $EDITOR to set your default text editor.
In the source code area, right-click, then select Edit Source or Edit Parent to open your default editor and edit the source.

**Selecting and Copying Text to the Clipboard**

You can select some or all text displayed in a Source Window, and copy it to your clipboard.

To select a portion of text in a Source Window:

• Drag your mouse across the text you want to select.

  DVE highlights the selected text.

*Figure 3-14  Selecting a portion of text*

To select all text and/or copy text in a Source Window:

1. Right-click and hold down the right mouse button in a Source Window.

   A context-sensitive menu (CSM) appears.

2. In the CSM, do any of the following:

   To select all text in the Source Window, choose **Select All**.

   To copy selected text from the Source Window, choose **Copy**.
Display Line Attributes

Use the line attribute area to toggle line numbering and control line breakpoints when running interactive simulation.

Toggle Line Numbering.

Right-click in the line attribute area, then select Line Number to toggle line numbering. Figure 3-16 shows the line attribute menu.
Controlling Line Breakpoints in the Source Window

You can control line breakpoints in the Source Window in two ways:

- Clicking on the circular breakpoint indicator in the line attribute area.
- Selecting a line breakpoint, right-clicking from the attribute area, then selecting a context-sensitive menu command.
The following table describes using the attribute area to control breakpoints:

<table>
<thead>
<tr>
<th>Breakpoint Icon</th>
<th>Description</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Breakable Line" /></td>
<td>Denotes that a breakpoint can be set on this line.</td>
<td>Click on the icon to enable the line breakpoint.</td>
</tr>
<tr>
<td><img src="image" alt="Breakable Line" /></td>
<td>Denotes that more than one breakpoint can be set on this line.</td>
<td>Click on the icon to enable a line breakpoint.</td>
</tr>
<tr>
<td><img src="image" alt="Enabled Breakpoint" /></td>
<td>Denotes a line breakpoint was set on this line, and it is enabled. Line stepping and simulators will stop on execution of this line.</td>
<td>Click on the icon to disable the line breakpoint.</td>
</tr>
<tr>
<td><img src="image" alt="Disabled Breakpoint" /></td>
<td>Denotes a line breakpoint was set on this line, and it is disabled. Line stepping and simulators will not stop on execution of this line.</td>
<td>Double-click on the icon to enable the line breakpoint.</td>
</tr>
</tbody>
</table>

**Enabling, Disabling, and Deleting Breakpoints with the Menu**

To use the attribute area context sensitive menu to control line breakpoints, do the following.

1. Select a breakpoint, then right-click in the line attribute area of the Source Window to display the context sensitive menu (Figure 3-17).
2. Select **Enable Breakpoint**, **Disable Breakpoint**, or **Delete Breakpoint** to change the line breakpoint condition.

For more information, see the following section, Managing Breakpoints in Interactive Simulation.
Setting Time Units and Precision

To set time units and precision:

1. Select **View > Set Time Scale**.
   
   The Set Time Units and Scale dialog box displays.

   ![Set Time Units and Scale Dialog Box](image)

2. Left click on the Display Precision down arrow to display selections.

3. Select unit and precision.

4. Click OK to set unit and precision.
Managing Breakpoints in Interactive Simulation

DVE allows setting of three types of breakpoints that cause the tool to stop when stepping or running during interactive simulation:

• Line breakpoints execute each time a specified line is reached during simulation (see the section “Display Line Attributes” on page 2-51 for more information) about line breakpoints. You can also specify an instance to have the tool stop only at the line in the specified instance.

• Signal breakpoints trigger when a specified signal rises, falls, or changes.

• Time breakpoints stop at a specified absolute or relative time in the simulation.

Creating Line Breakpoints

You can use the Breakpoints dialog box to create breakpoints in an interactive simulation.

To create a line breakpoint:

1. In the Source Window line attribute area or from the Simulator menu, right-click and select Set Breakpoints to display the Breakpoints dialog box (Figure 3-18).
2. Click **Define** to display the breakpoint creation tabs (Figure 3-19).
3. With the **Line** tab selected, enter the file name, or browse to the file where you want to create the breakpoint.

4. Enter the line number for the breakpoint.

5. Enter the instance where the breakpoint will fire.

6. If you want the breakpoint to fire only once, select **Once** for the Frequency, otherwise select **Repeat**.
7. You can optionally enter a condition to be met for the breakpoint to fire.

8. Click **Create**.

   The breakpoint is created and appears in the breakpoint list box.

---

**Creating a Time Breakpoint**

To create a time breakpoint:

1. In the Source Window line attribute area or from the Simulator menu, right-click and select **Set Breakpoints** to display the Breakpoints dialog box.

2. Click **Define** to display the breakpoint creation tabs.

3. Select the **Time** tab (Figure 3-19).

4. In the Time tab, select Absolute or Relative time, then enter the time at which to set the breakpoint (Figure 3-20).

*Figure 3-20  Breakpoint dialog box Me tab*
5. Click **Create**.

   The breakpoint is created and appears in the breakpoint list box.

---

**Creating a Signal Breakpoint**

To create a signal breakpoint:

1. In the Source Window line attribute area or from the Simulator menu, right-click and select **Set Breakpoints** to display the Breakpoints dialog box.

2. Click **Define** to display the breakpoint creation tabs.

3. Select the **Signal** tab. (Figure 3-19).

4. In the Signal tab, enter the desired signal (Figure 3-21).

   ![Breakpoint dialog box Signal tab](image)

5. Select Any, Rising, or Falling Edge to define the breakpoint event.

6. Enter the signal ID to trigger the break.
7. Click Create.

   The breakpoint is created and appears in the breakpoint list box.

---

**Enabling, Disabling, and Deleting Breakpoints**

To modify a breakpoint:

1. In the Source Window line attribute area or from the Simulator menu, right-click and select Set Breakpoints to display the Breakpoints dialog box (Figure 3-22).

   ![Figure 3-22 Breakpoints dialog box](image)

2. To work with defined breakpoints do one of the following:

   - To enable or disable a breakpoint, select or deselect its Enable box or select the breakpoint in the list and click Enable or Disable.

   - To delete a breakpoint, select the breakpoint in the list and click Delete.
Displaying Drivers and Loads

You can display active drivers and loads for a signal at a given time by backtracing the signal to the driver or load that caused a value change. The signal can be a Verilog signal, Verilog wire, VHDL variable, or Verilog register.

Displaying an Active Driver

The active driver of a signal is the driver that contributed to the value of the signal at a given time, time t.

- In Verilog, a driver is a signal assignment statement. In VHDL, a driver is a process (that contains a signal assignment statement).

- In Verilog, a contributor is an operand from the right-hand side of a (driving) signal assignment statement. In VHDL, a contributor is a signal that is a 'reader' for a driving process.

When you trace an active driver, DVE traces back from a given time and examines all potential drivers to a changed value in a potential driver. Drivers would look at all potential drivers of the target signal. For each of these drivers, the right-hand side of an assignment statement would be deciphered. DVE reports the first changed value in a driver before the given time.

You can analyze this contributor's affect on the target signal. If you are not satisfied that this signal is the reason the signal is the value it is, then you can ask to "step" back further. Active Drivers would then look for the next most recent contributor change and present this.
To trace an active driver, do the following:

Note: For 2005.06, before invoking DVE, you must set the environment variable as follows:

```
setenv DVE_Activedrivers 1
```

1. Select a signal from for a signal within the Source, Waveform, or Schematic, or List windows or the Data pane, then right-click and select select **Trace Drivers** from the context sensitive menu.

The Driver Window displays the driver for the selected signal.

**Example**

In the following, the signal result could be driven by one of three statements:

```plaintext
module one;
...
result = A + B
```
module two;
...  
result = C+D

module three
...
result = E+F

1. The active driver for result at time t1 is requested. Active drivers then looks up the three statements above, then determines that A, B, C, D, E, and F are contributors. Next active drivers looks for the most recent change among these signals, looking backward from time t1. Let's say at time t1-100, A changed value, while all the other contributors changed values previously. The statement, result = A + B, would be identified as A's active driver. If you were not satisfied with this (say this statement was within an if statement that was false), then you would request to "step back". Active drivers would then look back for the next most recent change to any of the contributors, starting at time t1-100.

Displaying an Active Load

A signal's load(s) are the input port(s), I/O port(s), and statements that read the signal's value. For example, the statement:

assign sigA = sigB

is a load for sigB.

An active load would be a load that is known to have read/used the updated value of the requested signal. Using the above example, if sigB changed to value 0 at time 100, then to 1 at time 150, and sigA changed to 0 at time 102, then this load would be active at time 102.

To trace an active driver, do the following:
3-65

Using the Top Level Window

Note: For 2005.06, before invoking DVE, you must set the environment variable as follows:

```bash
setenv DVE_ACTIVEDRIVERS 1
```

1. Select a signal from for a signal within the Source, Waveform, or Schematic, or List windows or the Data pane, then right-click and select select **Trace Loads** from the context sensitive menu.

The Load Window displays the driver for the selected signal.

![Diagram](image)

---

**Displaying Memory**

You can display contents of multi-dimensional arrays used for memory in the Memory Window:

1. Select a memory in Hierarchy pane.
2. In the Variable pane, select memory variables to view..

Using the Top Level Window

3-65
3. Right-click and select **Show Memory** to view the Memory Window contents.

![](image)

---

**Customizing Memory Display**

1. Right-click in the Memory Window, and select Properties. The memory properties dialog opens.

2. To change the memory display:
   - Enter a string value (Show row) or the number in the Columns to use to display the memory.
   - Specify a formula for the address computation based on index. Enter Start and End address to display for an address and index based on elements starting at 0. The Address is computed based on the specified formula.
   - Enter Start and End addresses to display only elements within the parameters.
Using the Top Level Window

- Enter a Radix

Using the Console

The Console provides a command-line interface and information about the commands you use during the session. You can use the console to enter TCL commands, view a transcript log of your session, view a list of commands you have used, and view a list of error and warning messages.

This section covers the following topics:

- Log View
- History View
- Errors/Warnings View

Figure 3-23 shows an example of the Console.

Figure 3-23  Components of the Console

Transcript of session

Tabs control active

TCL command-line interface

View in Console
Log View

The Log view is the active view when you first start DVE. This view, which corresponds to the Log tab, contains a complete transcript of all commands, error and warning messages, and reports generated by DVE.

You can copy text in the transcript and paste it at the TCL command line by selecting the text with your left mouse button and pasting it with the middle button.

You can use the Up Arrow and Down Arrow keys to scroll through the transcript.

See Figure 3-24 for an example of Log view.

Figure 3-24  Copying commands from Log view

Select text

Paste at command line using middle mouse button
History View

The History view displays a list of commands used during the current session. Each command you execute — whether from a menu or dialog box or on the TCL command line — is added to this command list.

You can copy text from the History view command list and paste it at the TCL command line by selecting the text with your left mouse button and pasting it with the middle button. Press the Return key to execute the command.

You can use the Up Arrow and Down Arrow keys scroll through the command list.

See Figure 3-25 for an example of History view.

Figure 3-25  Copying commands from History view

Select text
Paste at command line using middle mouse button
Errors/Warnings View

The Errors/Warnings view displays error and warning messages without including the comprehensive information provided in the Log view transcript. This enables you to scan messages at a glance.

To locate the origination of a message in your session transcript, you can double-click the error/warnings message. DVE will then display the corresponding Log view.

If you want to remove the messages and clear the view, click the Clear button in the CSM.

See Figure 3-26 for an example of Error/Warnings view.
**Figure 3-26** Viewing the origination of an error/warning message

```
1 <42> invalid command name "command>gui_sg_create"
2 <56> Error: unknown option 'iset' (CMD-010)
3 <58> Error: extra positional option 'file12' (CMD-012)
4 <50> Error: Required argument '-id' was not found (CMD-007)
5 <52>

command> gui_list_action -id Hier.1 [arb_testbench_top]
```

- Double-click error/warning message
- Origination of message appears in Log view
Command Line

You can use the command line to enter Unified Command Line Interface (UCLI) commands and TCL 8.3 commands for debugging a design.

Tip: You can enter multiple command lines if you separate the commands with a backslash character (\).

Note: The following briefly describes UCLI commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>abort</td>
<td>Halts evaluation of a macro file</td>
</tr>
<tr>
<td>alias</td>
<td>Creates an alias for a UCLI command.</td>
</tr>
<tr>
<td>change</td>
<td>Deposit a value on a variable. The tool may override this value.</td>
</tr>
<tr>
<td>call</td>
<td>Provides a unified interface to call both verilog/vhdl task/proc</td>
</tr>
<tr>
<td>config</td>
<td>Displays default settings for user’s variables.</td>
</tr>
<tr>
<td>do</td>
<td>Evaluates a macro script</td>
</tr>
<tr>
<td>drivers</td>
<td>Display a list of signals that drive the indicated signal.</td>
</tr>
<tr>
<td>dump</td>
<td>Specify value dump information (files, scopes/variables, depth to dump, enable/disable dumping, etc.) over the course of the tool processing</td>
</tr>
<tr>
<td>senv</td>
<td>Display the environment array or query an individual array element.</td>
</tr>
<tr>
<td>expr</td>
<td>This command displays the result of a VHDL evaluating expression.</td>
</tr>
<tr>
<td>finish</td>
<td>Finish/end processing in the tool.</td>
</tr>
<tr>
<td>force</td>
<td>Force a value onto a variable. Activity in the tool does not override this value.</td>
</tr>
<tr>
<td>get</td>
<td>Return the current value of the specified variable.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>help</strong></td>
<td>Display information on all commands or the specific command requested.</td>
</tr>
<tr>
<td><strong>listing</strong></td>
<td>List n lines of source on either side of the tool active location. If no number is entered, listing shows five lines on either side of the active location.</td>
</tr>
<tr>
<td><strong>loads</strong></td>
<td>Display the loads for the indicated signal for VCS only (no VHDL support).</td>
</tr>
<tr>
<td><strong>memory</strong></td>
<td>Loads or writes memory type values from or to files.</td>
</tr>
<tr>
<td><strong>next</strong></td>
<td>For VHDL code, next steps over tasks and functions. For Verilog, <code>next=step</code>.</td>
</tr>
<tr>
<td><strong>onbreak</strong></td>
<td>Specifies script to run when a macro hits a stop-point.</td>
</tr>
<tr>
<td><strong>onerror</strong></td>
<td>Specifies script to run when a macro encounters an error.</td>
</tr>
<tr>
<td><strong>pause</strong></td>
<td>Interrupts the execution of a macro file.</td>
</tr>
<tr>
<td><strong>release</strong></td>
<td>Release a variable from the value assigned previously using a force command.</td>
</tr>
<tr>
<td><strong>restart</strong></td>
<td>Restart the tool and stop at time zero.</td>
</tr>
<tr>
<td><strong>restore</strong></td>
<td>Restores simulation state previously saved to a file using the save command.</td>
</tr>
<tr>
<td><strong>resume</strong></td>
<td>Restarts execution of a paused macro file from the point where it stopped.</td>
</tr>
<tr>
<td><strong>run</strong></td>
<td>Advance the tool to a specific point. If some other event fires first then the ‘run’ point is ignored.</td>
</tr>
<tr>
<td><strong>save</strong></td>
<td>Saves the current simulation state in a specified file.</td>
</tr>
<tr>
<td><strong>scope</strong></td>
<td>Show or set the current scope to the specified instance. With no arguments the current scope is returned.</td>
</tr>
<tr>
<td><strong>show</strong></td>
<td>Show information about your design. You can specify multiple arguments.</td>
</tr>
<tr>
<td><strong>sn</strong></td>
<td>Execute Specman commands.</td>
</tr>
<tr>
<td><strong>stack</strong></td>
<td>Display stack information for the NTB or SVTB process/thread.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>start</td>
<td>Start the tool from within the TCL shell</td>
</tr>
<tr>
<td>status</td>
<td>Displays the macro file stack</td>
</tr>
<tr>
<td>step</td>
<td>Move the simulation forward by stepping one line of code. <em>step</em> will step into task and functions.</td>
</tr>
<tr>
<td>stop</td>
<td>Set a stop point in the tool.</td>
</tr>
<tr>
<td>thread</td>
<td>Display information regarding the current NTB or SVTB threads in the tool.</td>
</tr>
</tbody>
</table>
The Wave Window graphically displays waveforms of signal values and transition times.

The Wave Window is comprised of two primary sections: the Signal Pane and the Waveform Pane.

This chapter covers the following topics:

• Using the Signal Pane
• Using the Waveform Pane

For information on using the Wave Window to view and debug assertions see Chapter 5, Working with Assertions.
Viewing Waveform Information

To view waveform information for signals in the Wave Window:

1. Open a Wave Window by selecting in the toolbar or View >Wave Window.

2. Select a scope of interest from the Hierarchy Browser, Variable pane, Source Window, List Window, Schematic Window, or Assertion Window to the Wave Window, then right-click and select Add to Waves.

   or

In the Hierarchy pane or variable pane:

1. Select a signal or variable in the list.

2. Right-click and select Add to Waves from the context sensitive menu.

   or

   In the Assertions Failure Summary tab, double-click on an item in the list.

Figure 4-1 shows the Waveform Window with signal information.
Figure 4-1  The Waveform Window

Signal Pane

Waveform Pane

Using the Wave Window
Setting Wave Window Preferences

You can customize the list display in the Wave to:

- Turn on/off grid lines
- Display full hierarchical names or just the leaf names.
- Justify text left or right

To customize the display:

1. Select **Edit > Preferences**.
   
The Application Preferences dialog box displays.

2. In the Categories pane, select **Waveform Window**.

   **Figure 4-2 Wave Application Preferences dialog box**

3. Select or deselect **Show Grid**, and **Left Justify signal names and values** checkboxes, then select signal levels and marker value display.

Using the Wave Window

4-4
4. Click **Apply** to view your changes and keep the dialog box open, or click **OK** to apply your changes and close the dialog box.

5. Click **Reset** to reapply the defaults.

---

**Using the Signal Pane**

The Signal Pane is comprised of two columns:

- The **Name** column displays signal names
- The **Value** column displays the value of signals at the simulation time selected by the C1 cursor (which is also the value in the Top Level Window Time field).

See Figure 4-3 for an example of the Signal Pane.

**Figure 4-3  The Signal Pane**

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>clk</td>
<td>0</td>
</tr>
<tr>
<td>resel</td>
<td>1</td>
</tr>
<tr>
<td>grant[1:0]</td>
<td>2'h0</td>
</tr>
<tr>
<td>grant[1]</td>
<td>0</td>
</tr>
<tr>
<td>grant[0]</td>
<td>0</td>
</tr>
<tr>
<td>request[1:0]</td>
<td>2'hX</td>
</tr>
<tr>
<td>i[31:0]</td>
<td>X</td>
</tr>
</tbody>
</table>
The Display Radix

The Signal Pane displays signals in groups. Multiple signal groups can be viewed simultaneously in a wave window. Click the plus sign to see the contents and click the minus sign to hide the contents of a group. To divide signals into related signal groups right-click and select Signal Groups > Create Signal Groups.

Scalar signals have their value displayed in binary radix, Vector signals have their values displayed in hexadecimal radix. Integers, reals and times are displayed in the floating point radix.

Expanding Verilog Vectors, Integers, Time and Real Numbers

Vector signals can be expanded to their individual bits by clicking the plus icon to the left of the signal name. After you expand the display, each bit is added to the Signal Pane and waveforms for these bits are added to the Wave Window.

DVE represents integers in 32 bits so you can expand an integer in the Signal Pane to display separate waveforms for each of these bits. Similarly, DVE represents the time data type with 64 bits, and you can expand a time to display a waveform for each of these 64 bits.

You cannot expand a real data type.

Assertions can also be expanded. Upon expanding an assertion, its children will include the assertion clock and the signals and events (or sequences and properties for SVA) that make up the assertion.
# Using User-Defined Mnemonic Radices

This section describes how to create, edit, import, and export user-defined radices.

## Creating a User-Defined Radix

You can define a custom mnemonic mapping from values to strings for display in the Wave Window.

1. Select **Signal > Radix > User Defined** to display the Edit User-Defined Radix dialog box.

2. To create a user-defined radix, click **New**, enter a radix name, then press **Return**.

3. Click **Add Row** to activate a row for the user-defined radix.

4. Click **OK** or **Apply** to save the user-defined radix.

<table>
<thead>
<tr>
<th>Value</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>1'b0</td>
<td>ZERO</td>
</tr>
<tr>
<td>1'b1</td>
<td>ONE</td>
</tr>
</tbody>
</table>
5. To apply the user-defined radix to a signal, select the signal in the Wave Window, select Signal>Radix, then select the user-defined radix from the list.

Managing User-Defined Radices

To edit or delete a user-defined radix:

1. Select Signal>Radix>User Defined to display the Edit User-Defined Radix dialog box.

2. To delete a user-defined radix, select the radix from the User-Defined Radix pulldown menu, then click Delete.

   To edit a user-defined radix, select the radix from the User-Defined Radix pulldown menu, click a cell in the Value or Display table, then enter your change.

3. Click OK or Apply to save the change.

Importing and Exporting a User-Defined Radices

1. Select Signal>Radix>User Defined to display the Edit User-Defined Radix dialog box.

2. To import a radix click Import, then browse to and select the desired radix.

   To export a user-defined radix, click Export, select the radix from the User-Defined Radix pulldown menu, then enter a radix name.

3. Click OK or Apply
Setting Signal Groups

You can group signals and assertions for viewing in a Wave Window from both the Top Level Window and the Wave Window.

1. To create a signal group while working in a Wave Window click on New Group in the Signal Pane or right-click and select Signal Group>Create Signal Group from the context sensitive menu.

   A signal group is created.

2. Double-click on the newly created group, enter a name for the group, then press Return.

3. Select signals and assertions to include in the group, then drag and drop them into the group you created.

4. To delete a signal or signals from the group, select the signal or signals in the signal pane, right-click, then select Delete.

5. To control the display of signal groups, right-click, then select Signal Group>Display All Signal Groups or Signal Group>Display Signal Groups and check and uncheck the Groups to display or hide (see Figure 4-4 for an example).
Merging Signal Groups

Merge signal groups by selecting one or more signal groups in the Signal Pane, then dragging and dropping the selection into another signal group.

Using the Waveform Pane

The Wave Window displays the value transitions of signals and the success or failure of assertions.
The Wave Window has an upper and a lower timescale. The upper timescale displays the range of simulation times currently on display in the Wave Window. The lower timescale displays the range of simulation times throughout the entire simulation.
How The Wave Window Displays Values

For scalar signals the Waves displays a scaler waveform.

*Figure 4-6  Scalar Signal Waveform*

In this waveform for a scalar signal:

1. The signal has an X value from simulation time 0 to 5 indicated by a solid red bar.
2. The signal has a 1 value from time 5 to 10, indicated by the raised green line.
3. The signal has a 0 value from time 10 to 15, indicated by the lowered blue line.
4. The signal has a Z value from time 15 to 20, indicated by the yellow line positioned between the raised green and lowered blue lines.
5. The signal returns to an X value at time 20.

*Figure 4-7* shows vector signal values displayed in a stream of blue rectangles displaying hexadecimal values with a new rectangle for every value change. Vectors can have either red outline indicating some x values, a gold outline indicating no x, but some z, a gold line indicating all z and a red box indicating all x.
In Figure 4-7 the signal begins simulation with a hexadecimal d value, at time 10 it transitions to hexadecimal 100, and at time 20 to hexadecimal 200.

If you zoom out too far so that the Wave Window can no longer display transitions (see “Drag Zooming” on page 4-19), the waveform is a solid yellow bar (indicating multiple transitions at each pixel). Figure 4-8 shows two waveforms, one almost zoomed out too far, the other too far.

The Wave Window displays the execution of named events with upward pointing white arrows as shown in Figure 4-10.
Displaying Analog Waveforms

To view waveforms as analog signals in either a step or interpolated views and customize the analog display. To view an analog signal:

1. Select a signal in the Wave Window, then select **Signal > Edit Signal Properties** to display the Signal Properties dialog box.

2. To display the Style Schemes pulldown menu, click , then select the analog scheme as follows:
   - **analog** to display an analog waveform as a stairstep scheme, that stays at the value until the next reported value change.
- interpol to display an analog waveform interpolated between each reported value change.

Cursors and Markers

In the graphical display you can insert markers and cursors. To insert cursors:

- Click the left mouse button to deposit cursor C1 in the graphical display. The C1 cursors default position is at time 0. Left click somewhere else in the graphical display and cursor C1 moves to this new location.

- Click the middle mouse button to deposit cursor C2 in the graphical display. Similar to cursor C1, middle click somewhere else in the graphical display and cursor C2 moves to this new location.

To move cursors, place the mouse cursor on the round cursor handle in the cursor area, hold down the left mouse button and drag the cursor to the desired location. You can click either the left or the middle mouse button in the waveform or cursor area to move C1 or C2 respectively.

The interval between the two cursors is always displayed in the marker header area.
As shown in Figure 4-9, the simulation time and the delta between the reference cursor (C1) and cursor C2 is shown in the marker header area.

Markers differ from cursors in the way you insert and move them. Like cursors, markers display the delta between the reference cursor (C1) and the marker.

To insert a marker you can use the Markers dialog box, see “Using The Markers Dialog Box” on page 4-18, or do the following:

1. Right click in the graphical display. This brings up the context-sensitive menu (CSM) for the graphical display, as shown in Figure 4-10.
2. Select Create Marker from this menu. This inserts a dotted line on your mouse cursor in the graphical display.

3. The dotted line tracks the mouse cursor as you move the mouse in the waveform or marker header area. Position the marker in the graphical display then left click to position the marker.
As you insert markers, DVE names them M1, M2, M3 and so forth. You can rename them using the Markers dialog box.

**Using The Markers Dialog Box**

The Markers dialog box allows you to create, move, hide and delete markers and to scroll the graphical display until it reveals a marker. You open this dialog box with the **View -> Set Markers** menu command in the Wave Window.

![New Marker](image.png)
Click the **Tips** button to expand the dialog box to show context-sensitive help about the dialog box.

---

**Drag Zooming**

There are two ways to zoom in and out in the graphical display:

- Use the menu commands that cascade after the **Waveform>Zoom** menu command in the Top Level Window: **Zoom In**, **Zoom out**, **Zoom Full**, **Zoom to Time Range**, and **Zoom to Cursors**, or use their corresponding toolbar icons. There is also a Zoom command in the CSM for the graphical display.

- Drag zoom in the graphical display. Drag zooming is described here.
To drag zoom, move the mouse cursor to any point in either of the timescales or in the waveform display area, hold down the left mouse key and drag a region of the timescale. The selected region turns light blue. When you release the mouse key the graphical display changes its display to only those transitions in the selected region of the timescale.

### Expanding and Contracting Wave Signals

You can expand and contract the height of wave signals. Select View, then select **Increase Row Height** or **Decrease Row Height**.

### Searching in the Graphical Panes

When searching graphical panes, if any signals are selected in the wave window, searching will search only in the waveforms for the selected signals. If no signal is selected, it searches all the signals.

You can have the C1 cursor move from its current location to the next using the search forward and search backward arrows in the toolbar. To set the search criteria, click the down arrow in the toolbar and select one of the following:

- Any Edge
- Rising
- Falling
- Failure
- Success
- Value...
Customizing the Display

You can customize the list display in the Signal Group pane (as well as in the Top Level Window Hierarchy and Data panes) to:

- Turn on/off grid lines
- Justify text left or right
- Display full hierarchical names or just the leaf names.

To customize the display:

1. In the Top Level Window, select Edit > Preferences.

   The Application Preferences dialog box displays.

2. In the Categories pane, select List Settings, then click in the Wave item of the List Settings pane to expand the settings choices.

Figure 4-14  Application Preferences dialog box
Comparing Signals, Scopes, and Groups

You can compare individual signals with the same bit numbers, scopes (for comparing variable children), buses, or groups of signals from one or two designs.

To view a comparison:

1. Select one or two signals, signal groups, scopes, or buses from the Signal Pane of any DVE window.

2. To display the Compare Signals dialog box, right-click in the Signal Pane, then select Compare from the context-sensitive menu.

Figure 4-15. Waveform Compare dialog box
3. In the Reference Waveform area, if you did not select the reference design and signal in Step 1, select the reference design, then enter the compare reference region (signal, scope, or bus).

   Note: If you are comparing two designs from root, then the reference region and test region can be empty.

4. In the Test Waveform area, select the test design and the test region. If you are comparing two designs from root, then Reference Region and Test Region can be empty.

5. Select **Only Display Differences** to display only those results that do not match in the Wave Window.

6. In the Options section, you can choose one or both **Ignore X** and **Ignore Z** can be selected to ignore, For example, if you select Ignore X, if the reference signal value is X, there is always a match, whatever the values of the Test Signal.

7. Choose signals to compare by selecting one or all of **In Port, Out Port, Inout Port** and **Signals**

8. Click **Apply** to start the comparison and keep the dialog box open.

   Or

   Click OK to start the comparison and close the dialog box (you can open it at any time from the Signal Pane context-sensitive menu).

Results display in the current Wave Window.
9. To review comparison information, select a result in the Wave Window, right-click, then select **Show Compare Info**.

and the **Results Summary Report** displays in the Waveform Compare dialog box.

**Figure 4-17  Waveform Compare Summary Report**

10. You can change the options, then recompare.

---

**Building Buses**

Use the DVE Bus Builder function to create and edit buses containing signals as well as other user-created buses.
Create or edit a bus using the Bus Builder dialog from the Waveform Window. You can use either the Signal pull-down menu or the context-sensitive menu in the signal pane.

Include component signals by selecting signals in the signal pane of the Wave Window or by dragging or copying signals from the Hierarchy Browser into the Bus Builder dialog. You can add and delete signals or change their order in the bus. You can drag components to the List Window to view values.

After you create a bus is created, you can use it as you would any other signal in the design. By default it will reside in the highest level signal group common to its components.

**Bus Builder Dialog**

*Figure 4-18*, shows the major areas of the Bus Builder Dialog.

*Figure 4-18  Bus Builder Dialog*
Name

Name is the name of the signal bus. Buses can be named any legal name for the language (e.g., Verilog, VHDL). When opened in Edit mode, this field is inactive.

Bit Range

By default the bit range is 0 to N, where N is the number of components in the bus. Vectors and structs are expanded to their bits. For example, if “top.risc.pc[3..0]” is added to the list, it is added as four items.

Toolbar

The Bus Builder toolbar allows you to build and edit a bus. The following describes the Bus Builder toolbar commands.

<table>
<thead>
<tr>
<th>Toolbar Item</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Cut" /></td>
<td>Cut the selection from the component list.</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copy the selection from the component list.</td>
</tr>
<tr>
<td><img src="image" alt="Paste" /></td>
<td>Paste a copied component or components.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete the selection.</td>
</tr>
<tr>
<td><img src="image" alt="Move Down" /></td>
<td>Move the selection down in the component list.</td>
</tr>
<tr>
<td><img src="image" alt="Move Up" /></td>
<td>Move the selection up in the component list.</td>
</tr>
<tr>
<td><img src="image" alt="Reverse" /></td>
<td>Reverse the order of the selected components.</td>
</tr>
</tbody>
</table>
Components

Lists the components of the currently selected bus. When creating a new bus, you can select components in the Wave Window signal pane, right-click, then select Create Bus to include the selected components. When creating a new bus or editing an existing bus, you can drag signals into the components list from the Waveform Window and Hierarchy Browser. You can also use the toolbar commands to modify the components and their order.

Using Bus Builder

This section describes how to use Bus Builder to create and modify a bus.

Creating a Bus

To use Busbuilder to create a bus, do the following:

1. In the Wave Window Signal Pane, you select signals and buses to include in the new bus.

   Or

   Select no signals. You can choose components later.

2. Right-click in the Signal Pane or select Signal from the menubar, then select Create Bus.

   The Bus Builder dialog box displays.

3. Enter a name for the new bus.

4. To add signals and busses to the component list:

   - Drag and drop components from the Wave Window Signal Pane or the Hierarchy Browser.
- Select components in the Signal pane, select \texttt{Edit>Copy}, then click \textbullet{} in the Bus Builder toolbar.

5. Click \textbf{OK} to save the bus and display it in the Wave Window.

\textbf{Modifying Bus Components}

You can edit an existing bus or modify the components and their order in a new bus using the Bus Builder toolbar.

1. If you want to modify an existing bus, select the bus in the Wave Window signal pane, then right-click in the Signal Pane or select \texttt{Signal} from the menubar, then select \texttt{Edit Bus}.

2. To add signals and buses to the component list:
   - Drag and drop components from the Wave Window Signal Pane or the Hierarchy Browser.
   - Select components in the Signal pane, select \texttt{Edit>Copy}, then click \textbullet{} in the Bus Builder toolbar.

3. To delete components, select the components in the component list, then click \textbullet{} in the Bus Builder toolbar.

4. To move components up or down in the list, select one or more components in the component list, then click \textbullet{} or \textbullet{} in the Bus Builder toolbar.
5. To reverse the order of components relative to each other, select two or more components from the component list, then click in the Bus Builder toolbar.

6. Click OK to save the bus and display it in the Wave Window.

**Shifting Signals**

You shift a signal by creating a new signal based on a time shifted signal.

1. Select a signal in the Wave list.

2. Select Signal>Shift Time to display the Shift Signal dialog box.

3. Enter a positive Time Offset to shift the signal to the right or a negative number to shift to the left in the Waveform pane.

The signal displays with the original signal name followed by the time offset. In the above that is test1.risc.data[7:0]->>>10.
Using the Wave Window

4-30
The Assertion Window displays tabular assertion information in two ways:

Note: The Assertion Failure Summary tab displays assertion failures along with information such as start and end times of failures, the delta, the offending string, the instance name, and the assertion name.

- The Assertion tab shows all the assertions for a single scope. The scope will be an OVA unit or an SVA scope. An SVA scope is an HDL scope that contains SVAs.

Note: Use the VCS -assert dve command line switch with the -PP flag to enable SVA tracing in DVE. If you do not enable SVA tracing, assertion value changes will still be dumped into the VPD file and be visible in the Wave Window, but assertion attempts cannot be traced.
The two ways of populating the Assertion tab are:

- Click a scope containing SVAs or an OVA Unit from the Hierarchy Browser in the Top Level Window.
- Double click on a failure in the Assertion Summary Tab.

Once the Assertion Tab is populated with assertions it will list the statistics for all assertions, as well as those that contain failures, successes, and incompletes as limited by the filter settings.

As with other DVE windows that display tabular information, the tables on Assertion Window are customizable. You can sort, hide or expand columns, or change column order.

Figure 5-1 shows the two tabs of the assertion window with signal information displayed.
Figure 5-1  Customizing the Assertion Window display

<table>
<thead>
<tr>
<th>First Fail Ended</th>
<th>First Fail Started</th>
<th>Delta</th>
<th>Type</th>
<th>Instance</th>
</tr>
</thead>
<tbody>
<tr>
<td>7850</td>
<td>7750</td>
<td>100</td>
<td>Check</td>
<td>arb_testbench_top.arb1.arb_checker</td>
</tr>
<tr>
<td>7850</td>
<td>7750</td>
<td>100</td>
<td>Check</td>
<td>arb_testbench_top.arb1.arb_checker</td>
</tr>
</tbody>
</table>

Click a column head to sort by category.

Click and hold down a column header, then drag it to a new location.

Click and hold down at the right edge of a column header, then drag it to hide or change width.

Expand assertion to see results, double click result to trace.
Compiling SystemVerilog Assertions

Use the -assert dve flag on the VCS command line when compiling SystemVerilog assertions (SVA) for debugging with DVE.

**Tip:** The link step can take a long time if you use a Solaris linker prior to version 5.8. To avoid linking delays when using DVE to debug designs compiled on Solaris, do either of the following:

- Make sure your Solaris C compiler is version 5.8 or above. To check your compiler version, enter the following on the command line:

  ld -V

  The system returns your linker version, for example:

  ld: Software Generation Utilities - Solaris Link Editors: 5.8-1.283

- Use the gcc C compiler when compiling your design. For example:

  vcs -assert dve -PP -sverilog a.v -ld gcc

Using the Assertion Failure Summary Tab

When you open a design that contains assertions, DVE displays the Assertion Window even if all the assertions pass. If the design contains failed assertions, the Assertion Failure Summary tab displays the a number of failed assertions dependent on filter settings. This scrollable tab displays assertion failures along with the expression that might be the reason for the failure.
The Assertion Window is interconnected with other DVE windows. To display failed attempts in other DVE windows, double click an assertion attempt in the Assertion Failure Summary tab.

**Figure 5-2  Assertion Failure Summary Tab**

<table>
<thead>
<tr>
<th>First Fail Ended</th>
<th>First Fail Started</th>
<th>Delta</th>
<th>Type</th>
<th>Instance</th>
<th>Assertion</th>
<th>Offending</th>
</tr>
</thead>
<tbody>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.1.u6</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.1.u2</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.2.u2</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.u1</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.u3</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
<tr>
<td>7000000000</td>
<td>7000000000</td>
<td>0</td>
<td>Check</td>
<td>V1.top.u4</td>
<td>A1</td>
<td>outp1==inp1</td>
</tr>
</tbody>
</table>

The following occurs:

- The Assertion tab of the Assertion Window, is populated with data describing all assertions in an assertion unit or HDL scope.

- In the Top Level Window, the Hierarchy Pane displays the associated unit or HDL scope that contains the assertion.

- The Variable Pane displays the HDL variables corresponding to the unit or scope. This is not specific to the assertion (i.e., it may contains more signals that are used in the assertion).

- Up to three source windows may be displayed: one for the HDL source, one for the bind source and one for the OVA definition source.
• The Wave Window opens and displays the selected assertion centered on the failure. The cursors mark the start and end time of the selected assertion with the area between the cursors grayed. A green circle indicates a signal value at a specific time that contributed to successful sub-expression in the assertion. A red circle indicates a signal value at time that caused a sub-expression to fail. A sub-expression failing may result in the overall assertion failing.

Using the Assertions Tab

After you have selected an assertion failure in the Assertion Failure Summary tab or from another window the Assertions tab is populated with tabular data for all assertions in the assertion unit of a selected failed OVA or SVA assertion as well as the number of successes and attempts for all assertions and data describing failed assertions. The display of failures, successes, and incomplete attempts is determined by the filter settings (see the section Customizing the Display for more information).

Figure 5-3 shows an Assertions tab with the filter set to show 3 successes and 3 failures for each assertion if they exist.

**Figure 5-3  The Assertions Tab**
**Figure 5-4**

To expand the data, click the + sign next to an assertion name.

**Figure 5-5. The Signal Pane**

The display shows failure and success data.
To view assertion data in another window, you can drag and drop assertions of interest to a Source Window or a Wave Window. Or you can right click and select Show Source to view the selected assertion in a Source Window.

Customizing the Display

Setting Filters

You can set filters to control the data displayed in the Assertions tab.

1. Select **View > Filter Data** to display the Filter dialog box.

2. In the Filters pane, select the **Assertions** as the type of data to filter.

3. To set time filters:
- Select the checkbox next to **Show data from an end time of** and enter a time to begin displaying assertion data.

- Select the checkbox next to **Show data up to an end time of** and enter a time to stop displaying assertion failure data.

4. To filter by results, select or enter values for the number of failures, successes, and incomplete attempts to display.

5. Click **Apply** to view your changes and keep the Filter dialog box open, or click **OK** to apply your changes and close the dialog box.

6. Click **Reset** to reapply the defaults.

---

**Opening Assertion Display in a Top-Level Window**

To view assertions in a top-level window by default, select **Edit > Preferences**, select the **Debug** category, then deselect **Docked Assertion Window**.

---

**Displaying Assertion Attempts in the Waveform Window**

You can display traces of assertion attempts in the Wave Window the same way you display signal waveforms: by opening a Wave Window and dragging and dropping signals from the Hierarchy Browser and from a Source Pane. However, you can also use the Assertions Window to view traces of assertion attempts. The following sections provide more information.
Viewing Assertion Failures

When you open a design that contains failed assertions, in addition to the Top Level Window displaying the design in the Hierarchy Browser, DVE displays the Assertion Window with the Assertion Failure Summary tab. This tab displays assertion attempts and the expression that is the reason for failure.

To display failed attempts in the Wave Window, double click an assertion attempt in the Assertion Failure Summary tab.

Figure 5-6  Assertion Failure Summary Pane

The following occurs:

- In the Top Level Window, the Hierarchy Pane displays the selected assertion.
- The Variable Pane displays variable names and types for signals in the selected instance
- The Source windows display source code for the assertion.
• The Wave Window opens and displays the selected assertion centered on the failure. The cursors mark the start and end time of the selected assertion with the area between the cursors grayed. A green circle within a signal indicates a successful signal or value, while a red circle indicates a failure.

Figure 5-7  Displaying Failed Assertion Attempts

When first opened, the cursors mark the start and end time of the selected assertion with the area between the cursors grayed.

In the Waveform Pane:

- A green circle indicates a value within range of the selected assertion that would result in a success if other signals meet the assertion criteria.
- A red circle indicates a value outside the range of the selected assertion that causes or contributes to an assertion failure.

- White arrows indicate assertion clock events in the window.

- A gray background spans from attempt start time to attempt end time (instead of the normal black background). This is different from a gray bar in a waveform which indicates that there is no value change data for that simulation time. The background area remains gray if the cursors C1 and C2 are moved.

**Assertions in The Signal Pane**

For OVA and SVA assertions the Name column lists the name of the assertion, the Value column displays the result of the assertion attempt (Success, Failure, or NA) and the value of the relevant signals at the time at the C1 cursor or.
The assertion c_muxorsel in Figure 5-8 failed at time 0. Signal values that comprise the assertion are displayed.

If you open the assertion in the Signal Pane by clicking on the plus to its left, more information appears in the Signal Pane.

OpenVera Assertions in The Wave Window

The waveform for an assertion is a series of green arrows for successes and red arrows for failures. The start and end times of these successes and the start and end time and the reason for the failures is in the rectangles (if there is room, otherwise this information is truncated).
If you expand the assertion in the Signal Pane you see waveforms for the following:

- All the signals that are relevant for an assertion and the events that the assertion is made up of.
- For the result of the assertion with a success indicated by a green arrow, and a failure indicated by a red arrow.
- Incomplete attempts display as white bars. All incomplete attempts are at the end of the waveform for an assertion.

Figure 5-10  Displaying Assertion Data in the Wave Window
Navigating Source Code

DVE provides a source code navigation facility to aid in debugging.

To display code related to an assertion attempt:

1. Double-click an assertion attempt in either Assertion Window tab (see Figure 5-11).

*Figure 5-11  Select an assertion attempt*

Code is displayed as follows:

- The Source Pane in the Top Level Window displays the HDL code where the assertion is inlined or bound.

- A Source Window displays the assertion code with the assertion highlighted (see Figure 5-12).
2. To edit the assertion in your default text editor, select Edit>Edit Source.
Using the List Window

The List Window displays simulation results in tabular format. For Verilog, the List Window supports nets and register variables. For VHDL, it displays signals and process variables.

The List Window is comprised of three sections:

This chapter covers the following topics:

• The List Window
• Displaying Data
• Navigating Simulation Data
• Customizing the Display
• Saving a List Format

For information on using the Wave Window to view and debug assertions see Chapter 5, Working with Assertions.
The List Window

The List Window is comprised of three sections:

• The Signal Pane displays signal names as headers above the simulation data.

• The Data Pane displays simulation results in tabular format.

• The Simulation Time Pane.

Figure 6-1  The List Window
Displaying Data

This section covers the following topics:

- Dragging and Dropping Signals into the List Window
- Opening a Database
- Loading a Session

Dragging and Dropping Signals into the List Window

To populate the List Window with data from other DVE windows:

1. Open a List Window by selecting in the toolbar or View >List Window.

2. Drag and drop into the List Window a scope or assertion of interest from the Hierarchy Browser, the Source Pane, the Wave Window, from either tab of the Assertion Window.

The data is displayed in the default format.

Opening a Database

1. Open a List Window by selecting in the toolbar or View >List Window.

2. Select Edit>Open Database and select the .vcd, .vpd, or .dump database file to open or the saved session.
The data is displayed in the default format.

Loading a Session

To open a previously saved session, do the following:

1. Open a List Window by selecting in the toolbar or View > List Window.
2. Select Edit > Open Session and select the .vcd, .vpd, or .dump database file to open or the saved session.

The data is displayed in the default format.

Navigating Simulation Data

This section covers the following topics:

- Viewing Data in the List Window
- Using Markers

Viewing Data in the List Window

To view simulation data in the List Window:

- Use the bottom scroll bar to move left and right and view signals and their values.
- Use the right scroll bar to move up and down through simulation time.
• Select a signal in the signal pane to highlight the signal values as shown in Figure 6-2.
Using Markers

Set markers in the List Window to speed navigation:

1. Select **View>Set Markers** to display the Markers.List dialog box.

2. Click New to create a new marker in the list table.

---

Using the List Window
6-6
3. Select the Time cell for the new marker, enter the time at which to set the marker, click **Hidden** if you don’t want to display the marker in the Data Pane, then press Return.

4. Repeat steps 2 and 3 to create more markers.

5. Select a marker from the list in the Marker.List dialog box, then press **Jump** to move the data display to the selected marker.

   or

   Select **View>Goto Marker**, then select a marker from the list.

6. To remove a marker, select **Delete** in the Marker.List dialog box.

   or

   Select **View>Delete Marker**, then select the marker from the list.

---

**Customizing the Display**

This section covers the following topics:

- Setting Signal Properties
Setting Preferences

You can customize the list display to:

- Turn on/off grid lines
- Truncate signal names
- Display signals by levels
- Specify the space between columns

To customize the display:

1. Select **Edit > Preferences**.
   
The Application Preferences dialog box displays.

2. In the Categories pane, select **List Settings**.

![Application Preferences dialog box](image)

Figure 6-3  *Application Preferences dialog box*
3. Select or deselect Show Grid, Full Name, and/or Left Justify checkboxes.

4. Click **Apply** to view your changes and keep the dialog box open, or click **OK** to apply your changes and close the dialog box.

5. Click **Reset** to reapply the defaults.

---

### Setting Signal Properties

To customize signal display, you set signal properties for individual signals.

1. Select a signal in the Signal Pane.

2. Select **Signal>Signal Properties** to display the Signal Properties dialog box.

3. Enter the number of characters for the selected signal value column width.

4. Select whether a signal value change triggers a new line of values in the Data Pane.

5. Click **Apply** to make the change and keep to dialog box open to select and set more signal column widths.

   Or

   Click **OK** to apply the changes and close the dialog box.
Comparing Signals

You can compare signals in the List Window similar to the way you compare signals in the Wave Window. To view a comparison:

1. Select one or two signals, signal groups, scopes, or buses from the Signal Pane of any DVE window.

2. To display the Compare Signals dialog box, right-click in the Signal Pane, then select **Compare** from the context-sensitive menu.

*Figure 6-4  Waveform Compare dialog box*
3. In the Reference Waveform area, if you did not select the reference design and signal in Step 1, select the reference design, then enter the compare reference region (signal, scope, or bus).

Note: If you are comparing two designs from root, then the reference region and test region can be empty.

4. In the Test Waveform area, select the test design and the test region. If you are comparing two designs from root, then Reference Region and Test Region can be empty.

5. Select **Only Display Differences** to display only those results that do not match in the Wave Window.

6. In the Options section, you can choose one or both **Ignore X** and **Ignore Z** can be selected to ignore, For example, if you select Ignore X, if the reference signal value is X, there is always a match, whatever the values of the Test Signal.

7. Choose signals to compare by selecting one or all of **In Port, Out Port, Inout Port** and **Signals**

8. Click **Apply** to start the comparison and keep the dialog box open.

Or

Click OK to start the comparison and close the dialog box (you can open it at any time from the Signal Pane context-sensitive menu).

Results display in the current Wave Window.
9. To review comparison information, select a result in the Wave Window, right-click, then select **Show Compare Info**.

and the **Results Summary Report** displays in the Waveform Compare dialog box.

10. You can change the options, then recompare.
Saving a List Format

After you have customized the display in the List Window, you can save the format for future use. To save the List Format, do the following:

1. Select **File>Save List Format** to display the Save List Format dialog box.

2. Enter a filename with a .tcl extension for your format file.

3. Select **Save**.
This chapter contains the following topics.

• Overview
• Managing Schematic Displays
• Opening a Design Schematic View
• Note: If you hold the cursor on a signal, a tooltip identifies the signal as shown above.
Overview

Schematic views provide a compact, easy-to-read graphical representation of a design. View a design, scope, signal or group of selected signals and select ports to expand connectivity in relevant areas. Explore the design behavior by analyzing the annotated values for ports and nets.

Note: SystemVerilog design constructs are supported in the Schematic Window in this release as a beta feature.

There are two types of schematic views in DVE: design and path.

- A design schematic shows the hierarchical contents of a the design or a selected instance and lets you traverse the hierarchy of the design.

- A path schematic is a subset of the design schematic displaying where signals cross hierarchy levels. Use the path schematic to follow a signal through the hierarchy and display portal logic (signal effects at ports).

Note: Your design must be compiled in the same version of VCS that you are currently pointing to in your session.
Managing Schematic Displays

This section describes toolbar and menu commands for Managing schematics.

Selecting and Zooming Graphics

When viewing the schematic, you use the scroll bars to move up and down and left and right in the displayed graphics. You can also use toolbar and menu commands to select parts of the design to zoom in on or to copy or drag and drop into another DVE window.

The following table describes toolbar and menu commands.

<table>
<thead>
<tr>
<th>Toolbar Command</th>
<th>View Menu Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection Tool</td>
<td></td>
<td>Prepares the cursor for selecting objects (the default cursor).</td>
</tr>
<tr>
<td>Zoom In Tool</td>
<td></td>
<td>Prepares the cursor for zooming in. The cursor becomes a magnifying glass. Drag a bounding box around the area to enlarge.</td>
</tr>
<tr>
<td>Zoom Out Tool</td>
<td></td>
<td>Prepares the cursor for zooming out. The cursor becomes a magnifying glass. Drag a small box to zoom out by a large amount, or a large box to zoom out by a small amount.</td>
</tr>
<tr>
<td>Pan Tool</td>
<td></td>
<td>Prepares the cursor for panning the window view. The cursor becomes a hand shape. Point and drag to pan the view.</td>
</tr>
<tr>
<td>Zoom Full</td>
<td></td>
<td>Zooms out to display entire design.</td>
</tr>
<tr>
<td>Zoom In</td>
<td></td>
<td>Zooms in 2x.</td>
</tr>
<tr>
<td>Zoom Out</td>
<td></td>
<td>Zooms out 2x.</td>
</tr>
<tr>
<td>Zoom to Selection</td>
<td></td>
<td>Zooms to area selected with the Selection Tool.</td>
</tr>
</tbody>
</table>
Customizing the Display

To customize the schematic display, you can

- Set the maximum number of cells in the schematic
- Change the text style and size displayed on your schematics
- Change the visibility and colors of cells, hierarchical crossings, nets, busses, ports, pins, and rippers.

To customize the schematic display:

1. **Select Edit > Preferences**, then in the Category pane, select **Schematic Window**.

2. Click the up and down arrows to set the maximum number of cells as shown in Figure 7-1

   ![Figure 7-1 Setting Application Preferences](image)

3. Check and uncheck Visibility checkboxes to filter and inflater design elements from the display.

4. In the Line column, select colors for design elements.
5. To customize text size and style, click the + to display text selection options, then select the desired options.

6. To set value annotations, select Value Annotations, then click + in the Categories pane, then select Value Annotations.

7. Select the Port/Pin visibility, color, and font.

8. Do one of the following:
   - Click OK or Apply to display your changes and close or keep the dialog box open.
   - Click Cancel to ignore your changes and close the dialog box.
   - Click Reset and choose Reset Current Category, Reset All Categories, or Refresh Dialog.
### Displaying Schematic Graphics

The Schematic menu has commands for displaying schematics. The following table lists commands.

<table>
<thead>
<tr>
<th>Schematic Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Schematic Window</td>
<td>Opens a new schematic showing the contents of the currently selected scope.</td>
</tr>
<tr>
<td>New Path Schematic Window</td>
<td>Opens a new schematic showing the currently selected path.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Displays a design schematic for the selected design instance in the active schematic view.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Displays a higher-level schematic view of the parent design in the active schematic view.</td>
</tr>
<tr>
<td>Back&gt;</td>
<td>Displays the previous schematic from the history.</td>
</tr>
<tr>
<td>Forward&gt;</td>
<td>Displays the next schematic in the history.</td>
</tr>
<tr>
<td>Expand Path</td>
<td>Expands the selected path in the schematic window.</td>
</tr>
<tr>
<td>Add Fanin/Fanout</td>
<td>Displays the Add Fanin/Fanout to Adds the fanin logic to or fanout logic from a specified object in the currently active path schematic.</td>
</tr>
<tr>
<td>Annotate Pin Values</td>
<td>Displays values at the pins.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays attributes and values for the currently displayed schematic objects.</td>
</tr>
</tbody>
</table>
Using the Context-Sensitive Menu

A context-sensitive menu displays when you right click in the graphics area of a schematic view. The following table describes the commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Source</td>
<td>Displays the source code for the selection in the Source Pane.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Displays a design schematic for the selected design instance in the active schematic view.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Displays a higher-level schematic view of the parent design in the active schematic view.</td>
</tr>
<tr>
<td>Back&gt;</td>
<td>Displays the previous schematic from the history.</td>
</tr>
<tr>
<td>Forward&gt;</td>
<td>Displays the next schematic in the history.</td>
</tr>
<tr>
<td>Add Fanin/Fanout</td>
<td>Displays the Add Fanin/Fanout to adds the fanin logic to or fanout logic from a specified object in an currently active path schematic.</td>
</tr>
<tr>
<td>Annotate Pin Values</td>
<td>Displays values at the pins.</td>
</tr>
</tbody>
</table>

Opening a Design Schematic View

To view a schematic of an open design in DVE, note that your simulation needs to have been generated on the same platform you run DVE and you must have used the -debug command line option to compile.

To open a display design schematics do the following:

1. Select an instance from the Hierarchy Browser.
2. To choose between opening the schematic in the current active DVE window or in a new window, click to toggle the new window on and off.

3. To view a schematic: select **Schematic > New Design Schematic Window** or to view a design schematic.

The Schematic window displays the connectivity in the selected instance. Figure 7-2 shows an example of a hierarchical schematic a simple adder.
4. Use the zoom tool to zoom into the design.
5. Select Schematic > Annotate Pin Values.

Note: If you hold the cursor on a signal, a tooltip identifies the signal as shown above.

Opening a Path Schematic View

A path schematic is a subset of the design schematic displaying connections that cross hierarchical boundary. To open a path schematic view, do the following.

1. Open a design schematic view of an instance containing the hierarchical crossings of interest (See the previous section, Opening a Design Schematic View).

2. In the design schematic window, position the cursor on the instance you would like to display in the path schematic view. An identifying tooltip appears showing the ID.
3. When you have identified the instance to display, click on it to select it.

4. The color changes indicating it is selected.
   
   Your selection changes color confirming selection.

Note: You can also drag the selection cursor over multiple objects to select multiple items.

   Your selection changes color confirming selection.

5. Select **Schematic > New Path Schematic Window** or to view a path schematic.

   The path schematic for the selection displays.

   Figure 7-3 shows a path schematic.
Displaying Connections in a Path Schematic

With a path schematic displayed, you can by add the logic fanin to, or login fanout from, specified objects in the schematic across specified levels or the entire design. To display connections:

1. Select an object or objects in the path schematic.
   
   Your selection changes color confirming selection.

2. Select **Schematic > Fanin/Fanout to Path Schematic**.
The Fanin/Fanout to Path Schematic dialog box displays as shown in Figure 7-4.

**Figure 7-4**  *Add Fanin/Fanout to Path Schematic dialog box.*

3. Click the Set Selected button to add the selected objects to the list box. You can optionally select more objects and use the Add Selected button to add them to the list.

4. Set the other options such as the number of logic levels to be added and the Reuse Windows Options.

5. Click OK to update the schematic with the additional fanin or fanout logic.
The schematic displays as shown in Figure 7-5.

**Figure 7-5  Path Schematic**

---

**Manually Tracing Signals**

You can select one or more signals to trace in a Schematic or Path Schematic window. With this option, the selected signals are highlighted based on specified line colors you select.

To highlight signals:
1. Select **Trace > Highlight**, then select **Set Current Color**.

2. Select a color for the highlight.

3. Click **OK**.

---

**Following a Signal Across Boundaries**

You can select a signal and follow it across hierarchical boundaries in the Path Schematic window.

1. Select a signal or signals in any DVE list, then right-click and select **Show Path Schematic**.

2. In the Path Schematic window, select a signal.

3. Expand the hierarchy.
The signal is highlighted in the path view.

---

**Tracing X Values in a Design**

You can trace an X value through a design, for example, across gates, to identify the signal that caused the X value.

To trace an X value:

1. Select an instance from the Hierarchy Browser, then right-click and select **Show Schematic**.

   By default, a new Schematic window opens in the main window as a tabbed window.

2. Zoom schematic to fit window
3. Click the **Annotate Values** toolbar button in the Schematic window.

4. Select Schematic Window category.

5. Select the signal with an X value. The signal wire turns white when selected.

6. Select **Trace > Trace X**.
The x value is traced to its source signals making it easy to identify the signals that caused the X value.
Displaying Delta Cycles

You can use the Delta Cycle feature in the DVE Wave and List Windows to display detailed value change data, or delta cycles, that occurred within single sample times. If, for example, at time 800 you see that 8 signals changed state, you could expand time 800 to show the sequence of signal changes. Delta Cycle is also useful when investigating glitches or race conditions, where a signal may change multiple times within one sample time.

Delta Cycle Recording for Verilog

Enable reporting of delta cycle information in the VCD+ file using the `$vcdplusdeltacycleon` system task to use this function in post-processing mode.
The $vcdplusdeltacycleon system task enables reporting of Delta Cycle information from the VCD+ file. This must be followed by the appropriate $vcdpluson/$vcdplusoff commands.

The $vcdplusdeltacycleoff system task turns off reporting of Delta Cycle information starting at the next sample time.

When running in interactive mode, you go to the time of interest or search a signal for a value change. Then select Expand Time to view the delta cycle.

---

**Delta Cycle Recording for VHDL**

You can enable the capture of delta cycle information before simulating your design and not during runtime. To capture delta cycle information, set the VPDDELTACAPTURE variable to ON or OFF (default is OFF) in the .synopsys_vss.setup file or use the command line switch -vpddeltacapture on|off when simulating.

When viewing the simulation results in the waveform window, you can observe changes at the delta cycle level by pointing at a signal transition with the mouse and using the right-mouse button. A popup menu appears, select the Expand Time option to open up the series of transitions to show the sequence of delta cycle changes.

The trade-off for capturing delta cycle information is longer simulation runtime and larger VPD databases. Therefore, use this feature only for debugging delta delay problems.
Delta Cycle Recording for Mixed Designs for VCS MX

Delta Cycle recording for the entire mixed language design is not supported. It will work on respective portions of the design. You can get Delta Cycle data using -vpddeltacapture switch for scsim at run-time.

Using Delta Cycles

Expand and Collapse Times

To expand a time to view delta cycle information:

1. In the Wave Window:
   - Enter the time of the delta cycle in the Time box in the toolbar and press Return.
   - Or,
   - Select a signal in the Signal Pane, select Any Edge in the toolbar, then click the direction to search.

   In the List Window, select the Signal in the Signal Pane, then select the time to view.

2. Right-click, then select Expand Time from the CSM.
You can collapse either all delta cycle regions or a selected delta cycle region. To collapse all delta cycle regions, right click anywhere in the Waveform Pane and select Collapse All Time from the CSM. To collapse a single delta cycle region, right click in the region to open the Waveform Pane CSM and select Collapse Time.

---

**View Delta Cycles**

When you expand a time in a Wave Window, a delta cycle area is inserted into Wave pane at the selected time. Figure 8-1 shows the signal inc_pc changes value twice within time 100. The order in which the displayed signals changed is also shown.
Figure 8-1  Delta cycle in the Wave Window.

Note:
Delta cycle waveform areas do not zoom.

When you select a expand a time in a List Window, a delta column displays the change values and the signal and data lists expand to display the details. Figure 8-2 shows time expanded at 100. The view can be scrolled right to review value changes.
You can collapse either all delta cycle regions or a selected delta cycle region. To collapse all delta cycle regions, right click anywhere in the Wave or Time Pane and select Collapse All Time from the CSM. To collapse a single delta cycle region, right click in the region to open the Waveform Pane CSM and select Collapse Time.
Displaying Values in Wave Window Delta Cycle Regions

With a selected time expanded, click within an expanded time to display the signal values at the location of the cursor C1. Figure 8-3 shows cursor C1 at the falling edge of signal inc_pc. The value displayed in the Signal Pane is 0. If the rising edge had been selected, the value would be 1.

*Figure 8-3  Wave Window delta cycle value displayed*
Displaying Delta Cycles
Basic Navigation Techniques

This chapter describes the basic navigation techniques for using DVE in a simulation analysis.

The following topics are covered:

• Using Mouse Buttons
• Using Context Sensitive Menus
• Using Workspace Windows

Using Mouse Buttons

You can use your left and right mouse buttons to perform a variety of tasks in DVE, such as selecting and displaying data, opening and closing windows, and selecting analysis criteria.
Note: If you are using a three-button mouse, the middle button functions the same as the left button.

The following table shows the various tasks you can perform using your left mouse button:

<table>
<thead>
<tr>
<th>Task</th>
<th>For more information...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select scopes, variables, assertions, or text.</td>
<td>See &quot;Selecting Scopes, Variables, Assertions, and Text&quot; on page 1-3.</td>
</tr>
<tr>
<td>Drag and drop scopes, variables, and assertions into the Signal Pane of the Waveform Window.</td>
<td>See &quot;Dragging and Dropping Data into the Waveform Window&quot; on page 1-5.</td>
</tr>
<tr>
<td>Expand and collapse the display of data in the Hierarchy Browser.</td>
<td>See Chapter 3, &quot;Using the Hierarchy Browser.&quot;</td>
</tr>
<tr>
<td>Display data in the Waveform Display.</td>
<td>See Chapter 3, &quot;Using the Waveform Display.&quot;</td>
</tr>
<tr>
<td>Set marker positions in the Waveform Display.</td>
<td>See Chapter 3, &quot;Using the Waveform Display.&quot;</td>
</tr>
<tr>
<td>Select menu options in dialogs.</td>
<td>Covered throughout the DVE User Guide</td>
</tr>
</tbody>
</table>

The following table shows the tasks you can perform using your right mouse button:

<table>
<thead>
<tr>
<th>Task</th>
<th>For more information, see...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create markers in the Waveform Display.</td>
<td>See Chapter 6, &quot;Using the Waveform Display.&quot;</td>
</tr>
<tr>
<td>Display a context sensitive menu that enables you to open, close, and arrange windows.</td>
<td>See “Using Context Sensitive Menus” on page 1-8.</td>
</tr>
<tr>
<td>Display a context sensitive menu that enables you to manipulate the display of data in the Waveform Display.</td>
<td>See “Using Context Sensitive Menus” on page 1-8.</td>
</tr>
</tbody>
</table>
Selecting Scopes, Variables, Assertions, and Text

You can use your left mouse to select data of all types (scopes, variables, assertions, and text) within any DVE window. The following table shows the various ways you can select data in DVE:

<table>
<thead>
<tr>
<th>To</th>
<th>Do This</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an individual scope, assertion or variable.</td>
<td>Click left on the scope or signal.</td>
<td>Selects and highlights a new scope, variable, or assertion</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sets an anchor point at the selected scope, variable, or assertion for range selection.</td>
</tr>
<tr>
<td>Select a range of text (word, etc.)</td>
<td>Click and drag over the range of text.</td>
<td>Selects and highlights a range of text.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sets an anchor point at the selected text for range selection.</td>
</tr>
<tr>
<td>De-select all scopes, variables, assertions, and text.</td>
<td>Click left in another window.</td>
<td>Deselects all data.</td>
</tr>
<tr>
<td>Select a sequential range of data.</td>
<td>Select the first variable, assertion, scope, or word, press Shift, and click left on the last signal.</td>
<td>Selects and highlights all data in the range.</td>
</tr>
<tr>
<td></td>
<td>Click left on the first variable, scope, assertion, or word, and drag your mouse over the data in the range.</td>
<td></td>
</tr>
</tbody>
</table>
Basic Navigation Techniques

Drag and Dropping Data into the Waveform Window

You can drag and drop scopes, variables, or assertions from the Hierarchy Browser or Assertion tab into the Signal Pane of Waveform Window.

To drag and drop scopes, variables, or assertions for display in the Waveform Window:

1. Depress and hold down your left mouse button to select a scope, variable, or assertion.

2. Drag the selected scope, variable, or assertion to the Signal Pane of the Waveform Window and release your mouse button.

The selected data displays in the Waveform Window.

<table>
<thead>
<tr>
<th>To</th>
<th>Do This</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle-select individual variables or scopes without de-selecting.</td>
<td>Press Ctrl and click left on a scope or signal.</td>
<td>Selects or de-selects the scope, variable, or assertion you are pointing at without deselecting other variables. Resets the anchor point when you want to select/deselect multiple non-contiguous ranges of scopes, assertions, and variables within the same list.</td>
</tr>
</tbody>
</table>
Figure 9-1  Dragging and Dropping Data into the Waveform Window

Drag and drop assertion from the Source Window to the Signal Pane in the Waveform Window

2 Waveform Window displays data
Using Context Sensitive Menus

Context sensitive menus appear on your screen when you right-click on various areas within the DVE Top Level Window.

If you right-click anywhere over the Menu bar or Toolbar, the menu shown in Figure 5-2 appears.

Figure 9-2  Context sensitive menu over the toolbar

This menu enables you to close and open various and toolbar icon sets by selecting the corresponding checkbox.

If you right-click anywhere over the Hierarchy Browser the menu shown in Figure 5-3 appears:
This menu includes the following selections:

**Add to Waves** — Loads the selected signal in the Waveform Display.

**Select All** — Selects all scopes or variables in the active window.

**Expand** — Expands the hierarchy display in the active window.

**Collapse** — Collapses the hierarchy display in the active window.

**Show Source** — Displays the Source Pane for the currently active window.

See Chapter 3, "Using the Hierarchy Browser" for details on using this menu.

If you right-click anywhere over a Source Pane, the menu appears:
You can use this menu to copy selected portions of text, or select the entire text in the Source Pane.

If you right-click over the Signal Name (left) column of the Waveform Window, the menu shown in Figure 5-5 appears.
If you select this option, DVE will display the Source Pane corresponding to the selected signal.

If you right-click over the Waveform Window, the menu shown in Figure 5-6 will appear.
Figure 9-6  Context sensitive menu over the Waveform Pane

You can use this menu to set various waveform display characteristics. See Chapter 5, "Using the Waveform Display" for Using Docked Windows

Docked windows include all DVE windows. You can reposition these windows anywhere within the workspace boundaries of the DVE Top Level Window, or anywhere on your monitor screen outside the Top Level Window.

See Figure 5-7 for an example of docked windows inside workspace boundaries.
To reposition a docked window anywhere on your screen, click and hold down the grab bar of any docked window, and drag the window to the intended position.
To minimize a Docked Window:

1. Make sure the Docked Window is inside the boundaries of the Top Level Window.
2. Click the grab bar of the window.

The Docked Window minimizes.

Figure 9-9  Minimized Docked Window

Using Toolbar Icon Sets as Floating Tool Palettes

You can maneuver sets of Toolbar icons to any position on your monitor screen by dragging and dropping them as floating tool palettes.

To use a Toolbar icon set as a floating tool palette:

1. Click and hold down your left mouse on the grab bar of a Toolbar icon set.
2. Drag the icon set to any location on your screen, then release your mouse button.

The icon set become a floating tool palette. See Figure 5-12.
Figure 9-11 Maneuvering Toolbar icon sets as floating tool palettes.
Minimizing, Maximizing, and Moving Toolbar Icon Sets

You can minimize, maximize, or move icon sets anywhere on the Toolbar:

To minimize a Toolbar icon set:

• Click on the grab bar of the icon set.

The icon set minimizes. See Figure 5-13.

Figure 9-12  Minimizing Toolbar icon sets

To maximize a Toolbar icon set:

• Click the grab bar of a minimized icon set.

The icon set returns to its original position and size on the Toolbar.
To move an icon set to a different position on the Toolbar:

- Click on the grab bar of the icon set and drag it to any location on the Toolbar. See Figure 5-14.

*Figure 9-13  Moving an Icon Sets to a different location on the Toolbar*
Index

A
About DVE (Help menu selection) 3-18
Active Driver 3-62
Active Load 3-64
Active Scope 3-13
Add Fanin/Fanout 3-14
Add to Lists 3-12
Add to Waves 3-12
Add to Waves (CSM selection) 9-7
Annotate Values 3-14
Architecture 3-14
Assertion 3-13
assertion attempt 1-19
Assertion Attempts 3-14
Assertion Failure Summary Pane 5-4
Assertion failures 5-4
Assertion Unit 3-34
Assertion Window 3-16, 5-1
assertions
definition of 1-19
displaying in Signal pane 5-12
displaying in Waveform pane 5-13
dragging and dropping 9-4
selecting 9-3
attempt, assertion 1-19
audience 1-ii

B
Back 3-13
basic navigation techniques 9-1
Beginning (menu selection) 3-8
binary radix 4-6
bits, displaying in waveform 4-6
Breakpoints 3-11
Building Buses 4-24
Bus Builder 4-24
buses, building 4-24

C
C1 cursor 4-5
Capture Delta Cycle Values 3-11
Cascade (Window menu selection) 3-17
Clear button 3-70
Close Database
  Toolbar icon 3-22
Close Database (File menu selection)
  reference 3-5
Close Database confirmation dialog box 2-28
Close File (File menu selection)
  reference 3-5
Close Window (File menu selection)
  reference 3-5
closing a VPD database 2-28
Collapse (CSM selection) 9-7
collapsing the hierarchy tree 3-31
column headings
  rearranging 3-38
command list 3-69
commands
  transcripts of 3-68
Compare 3-12
concepts, key 1-19
Console
  using 3-67
Console Pane 3-15
Context Sensitive Menu (CSM)
  definition of 1-19
context sensitive menu (CSM)
  Add to Waves 9-7
  Collapse 9-7
  Expand 9-7
  over Hierarchy Browser 9-6
  over Signal Pane 9-9
  over Source Pane 9-7
  over Toolbar 9-6
  over Waveform pane 9-9
  Select All 9-7
  Show Source 9-7
context sensitive menus (CSMs)
  using 9-6
Continue 3-10
copying text 3-68
Create Bus 3-12
Create Marker (CSM selection) 4-17
Create Signal Groups 3-11
cursor C1 4-15
cursor C2 4-15
cursors, inserting 4-15
Customizing the assertion display 5-8

D
Data Pane
  loading 2-14
  Toolbar icon 3-23
database
  closing 2-28
  opening 2-6
Delete All Breakpoints 3-11
Delete Breakpoint At 3-11
de-selecting scopes, variables, etc. 9-3
Design Root icon 3-34
Display All Signal Groups 3-12
Display Signal Groups 3-11
displaying
  scope data 3-36
Dock
  Window menu selection 3-17
docked window
  minimizing 9-12
docked windows
  using 9-10
Drag and Drop
  definition of 1-19
drag zooming 4-19
dragging and dropping
  data 9-4
  example 9-5
  Toolbar icon sets 9-17
drivers and loads, displaying 3-62
Dump Values 3-5
DVE
  exiting 2-28
  starting 2-3, 3-2
DVE Help (Help menu selection) 3-17

E
Edit Bus 3-12
Edit menu, reference 3-6
Edit Parent 3-14
Edit Source 3-14
Edit User-Defined Radices 3-12
End (View>Go To menu selection)
reference 3-8
Entity 3-12, 3-13
error and warning messages 3-68
Errors/Warnings view (tab) 3-70
Execute Tcl Script
Toolbar icon 3-22
Execute Tcl Script (File menu selection)
reference 3-5
Exit (File menu selection)
reference 3-5
exitingDVE 2-28
Expand (CSM selection) 9-7
expand and collapse
definition of 1-19
Expand Path 3-14
expanding
view of scopes 3-30

F
File menu, reference 3-5
File Toolbar 3-9
Filter Data...(View menu selection)
reference 3-9
Find (Edit menu selection)
reference 3-6
floating tool palettes
using 9-13
Forward 3-13

G
Go To (View menu selection)
reference 3-8
grab bar
example 9-13

H
help
Synopsys Technical Support Center 1-iii
Help Toolbar 3-10
hexadecimal radix 4-6
Hierarchy Pane 3-16
History view (History tab) 3-69
icons
Design Root 3-34
Verilog Function 3-34
Verilog Instance 3-34
Verilog Named Begin 3-34
Verilog Named Fork 3-34
Verilog Task 3-34
information, other sources 1-ii
inserting new markers 4-18
integers, storing 4-6
interval between cursors 4-15
invoking DVE 3-2
invokingDVE 2-3

K
key terms and concepts 1-19

L
left mouse button
using 9-1
List Window 3-16
customizing 6-7
panes 6-2
save format 6-13
set markers 6-6
set signal properties 6-9
using 6-1
view simulation data 6-4
Load Session (File menu selection) reference 3-5
loading a VPD database 2-6
loading Data and Source Panes 2-14
Log view (Log tab) of console 3-68
lower timescale 4-11

M
Main Window
  example 1-4
  initial appearance 2-4
  overview 1-2
  using 3-1
manual
  audience 1-ii
Markers dialog box 4-18
markers, inserting 4-15
maximizing
  Toolbar icon sets 9-16
Menu Bar
  reference 3-4
  using 3-2
messages, error and warning 3-68
minimizing
  docked windows 9-12
  Toolbar icon sets 9-16
mouse buttons
  using 9-1
Move Down to Definition 3-13
Move Up to Parent 3-13
moving
  Toolbar icon sets 9-13

N
Name column (signal pane) 4-5
navigating
  Hierarchy Browser 3-30
navigation basics 9-1
new markers, inserting 4-18
Next 3-11

O
oads, displaying 3-62
Open Database
  Toolbar icon 3-22
Open Database (File menu selection)
  reference 3-5
Open Database dialog box 2-6
Open File (File menu selection)
  reference 3-5
opening
  database 2-6
OpenVera Assertions (OVA)
  definition of 1-20
origination of a message, finding 3-70

P
pasting text into Tcl command line 3-68
Periodic Waveform Update Interval command 3-11

Q
Quick Start Example
  Toolbar icon 3-25
quitting DVE 2-28

R
radix
  binary 4-6
  hexadecimal 4-6
range of text
  selecting 9-3
rearranging column headings 3-38
Release Notes 3-17
Reload Database 3-5
Repeat Last Trace 3-15
repositioning
    Toolbar icon sets 9-17
repositioning docked windows 9-10
repositioning Toolbar icon sets 9-13
Restore State 3-11
right mouse button
    using 9-1
right-click 9-6
Root icon 3-32
Run 3-10
Run Example (Help menu selection) 3-18

S
Save Session (File menu selection)
    reference 3-5
Save State 3-11
scalar signal
    example 4-12
scalar signals 4-6
scanning messages at a glance 3-70
scope
    definition of 1-20
Scope Types
    example 3-29
Scopes
    example 3-29
scopes
    dragging and dropping 9-4
    selecting 9-3
Search Backward 3-12
Search Forward 3-12
searching in the Waveform pane 4-20
Select All (CSM selection) 9-7
selecting
    scopes 3-36
selecting scopes, variables, etc. 9-3
sequential range of data
    selecting 9-3
Set Continue Time 3-11
Set Default Wave Window 3-17
Set Expression 3-12
Set Precision text field 3-22
Set Radix 3-12
Set Search Constant 3-12
set signal properties 6-9
Set Time text field 3-22
Setup 3-10
Shift Time 3-12
Show 3-13
Show Comparison Info 3-12
Show Drivers and Loads 3-14
Show Memory 3-12
Show Path Schematic 3-13
Show Schematic 3-13
Show Source 3-13
Show Source (CSM selection) 9-7
signal
    vector 4-12
Signal Groups 3-11
signal groups 4-6
signal information, displaying 5-2
Signal Menu 3-11
Signal Pane
    context sensitive menu (CSM) 9-9
Signal pane
    using 4-1
Signal Properties 3-13
signals
    scalar 4-6
    vector 4-6
Simulate Toolbar 3-10
simulation time
    setting
        example 3-3
Source Pane
    context sensitive menu (CSM)
        9-7
loading 2-14
  Toolbar icon 3-24
Source Toolbar 3-10
starting DVE 2-3, 3-2
Step 3-10
steps in flow for using DVE 1-14, 1-16, 1-17
Stop 3-10
support
  Synopsys Technical Support Center 1-iii

T
Tcl command line
  pasting text into 3-68
Terminate 3-11
terms, key 1-19
text
  selecting 9-3
text, copying 3-68
Tile (Window menu selection) 3-17
time
  simulation
    setting 3-3
time data type 4-6
Time... (View>Go To menu selection) reference 3-9
Tips button 4-19
Toolbar
  using 3-2
Toolbar icon sets
  maximizing 9-16
  minimizing 9-16
  repositioning 9-13
Toolbars 3-9
Trace Drivers 3-14
Trace Loads 3-14
transcript of all commands 3-68

U
Undock 3-17
Unit Binding 3-13
upper timescale 4-11

V
Value column (Signal pane) 4-5
value transitions 4-10
variable
  definition of 1-21
variables
  dragging and dropping 9-4
  selecting 9-3
vector signal 4-12
vector signals 4-6
Verilog Function icon 3-34
Verilog Instance icon 3-34
Verilog language
  definition of 1-22
Verilog Named Begin icon 3-34
Verilog Named Fork icon 3-34
Verilog Task icon 3-34
View menu, reference 3-7
VPD file
  closing 2-28
  loading 2-6

W
Wave Window 3-16, 3-17
Waveform pane
  context sensitive menu 4-17
  context sensitive menu (CSM) 9-9
cursors 4-15
Waveform pane, using 4-1
Waveform Window
  dragging and dropping 9-4
  overview 1-8, 1-9
Window Menu
reference 3-15
Window Toolbar 3-10
workspace boundaries, identifying 9-11

\[ Z \]
zooming
by dragging 4-19